Firebase error: Domain did not match expected domain filter(s) ``

  • 3 January 2024
  • 6 replies

Hello there,

I have created a zap action that sign up a new user on my firebase project. However while testing my action i always get the following behavior:

URL that firebase documentation provides:

error message i always get while trying my request: 

"Error during execution: Domain did not match expected domain filter(s) ``."



  • my other zap action works on my firebase project (create documents...)
  • my firebase project is properly configured to allow user account creation with only mail and password
  • i have verified my API_KEY 
  • i am using an admin firebase project account to trigger the action which has all possible authorizations on my firebase project

Any hints to solve this issue ? After having read all documentation from firebase i am running out of ideas…


Thank you for the support 

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @Healthy Mind Lubin 

We would need to see screenshots with how your Zap step is configured to have true context.

Try creating a custom action with the help of AI.


Hello troy, 

Thank you for the quick answer. First attempt has been performed using the AI custom actions. By creating the http request manually on zappier, result is the same. See screenshots.

Strage observation is that sending the same request with postman tool works perfectly...

Userlevel 7
Badge +14

@Healthy Mind Lubin 

The custom action via AI expects this URL domain:


You are using this domain.



Maybe try a different Google Zap app?


Thank you for your answer Troy,


Unfortunately Google Workspace Admin is not appropriate for the action we are trying to configure. It cannot interact with firebase as we expect. We just want to sign up a new user on a firebase project. According to google/firebase documentation we have to use the previously mentionned URL to achieve this goal: There is no other way.

Other tools on internet that don’t have this URL name filter issue we observed on zappier, perfectly work for HTTP request. However they don’t offer an configuration interface as convenient as zappier does.

Would it be possible to just deactivate this check you do on firebase http request URL ? this would improve possibilities for Firebase/Zappier interactions. A lot of other features from firebase, request to use URLs that don’t contain domain…

By the way, what is the purpose behind this requirement (blocking URL which does not contain on your side ? 


Thanks a lot for the provided support,

We finaly found a way to workaround the issue. We just have used webhooks to implement our action, this works perfectly. 

I think you implemented the limitation of domain name to restrict actions to firestore. However firestore is just a part of firebase features. 

Thanks a lot for your answers ! zapier is a great tool, have a nice day !

Userlevel 7
Badge +14

@Healthy Mind Lubin 

Other options for using App APIs in Zaps: