Best answer

Failure to move file from previous step in Google Drive

  • 13 September 2023
  • 5 replies

Userlevel 1

I have a zap that imports a CSV file from Google Drive, loops through the csv file and inserts rows into Smartsheet. I have tried to add a step to move the file to an archive folder in Google Drive. When I try to test the step I get the error: 

Failed to create a move file in Google Drive

'NoneType' object has no attribute 'get'

 The file is specified as 1.File: (exists but not shown) from the initial step New File in Google Drive. The Zap I am working on is “Import Staff Data From Workday”


Any ideas would be appreciated, I have tried everything that I can think of… Thanks!




Best answer by Troy Tessalone 13 September 2023, 17:31

View original

5 replies

Userlevel 7
Badge +14

Hi @KBradford 

Good question.

If you are manually testing the Zap, make sure to retest each Zap step.

The File object is a temp file that expires.

Userlevel 1

Thanks, Troy. I just retested each step, and got the same result. I also published it and tested it, same error...

Userlevel 7
Badge +14


The File field expects the File ID, not a file object/url.


Userlevel 1

That worked great, thanks! As a new user, how would one know that? Previous steps wanted the object. Is there documentation specifying what the exact input is looking for (since the step just shows ‘File’)?

Thanks again

Userlevel 7
Badge +6

Hi @KBradford,

I’m jumping in to see if I can help!

You will see the difference in the field itself when it’s a dropdown field sometimes the field asks for the ID. You can learn more about this here:

Hopefully, this helps! 😊