Best answer

Failed to find a spreadsheet row in Google Sheets: Error from halted execution; nothing could be found for the search

  • 23 June 2023
  • 5 replies
  • 394 views

I have 1 zap that creates a Google Sheet spreadsheet row (below) that works perfectly. In that zap I have an action that sends the phone number to storage by zapier for later use.

 

My issue is with a 2nd independent zap whereas when performing lookup Google sheet spreadsheet row (below) using the phone number (from storage) it returns:

Failed to find a spreadsheet row in Google Sheets

Error from halted execution: Nothing could be found for the search.

 

Here’s a screenshot of my Google Sheet:

 

icon

Best answer by Skippy 23 June 2023, 17:55

View original

5 replies

Userlevel 7
Badge +12

Hi @Skippy 

My first inclination here is to test if the “+” in front of the phone number. It may be causing the issue as it would not match identically.

I would do a few tests to see if that is the case.

I thought the same thing. When you click on the field the + shows in the formula bar. I just ran another test whereas I put the number in the phone field of the 1st zap (which is fine for troubleshooting but would never work in practice). then tested my lookup action in the 2nd zap and got the same failed result. 

Userlevel 7
Badge +12

In the second zap with the lookup step, could you replace the mapped field with a static value of a number you want to search for?

 

By that I mean, you would change

to look like this where the number would be an exact match of what is in the spreadsheet.

Then test the action.

I just solved it! In the 1st zap I used formatter to do away with any country codes and it worked. Thanks for the input.

Userlevel 7
Badge +6

Hi @Skippy,

Awesome! Glad to hear that you solved the issue with the help of GetUWired.

If you have any other questions, please don’t hesitate to ask in the Community. We’re always happy to help! 😊

Reply