Failed to find a file in OneDrive: While requesting "dev_method" from OneDrive we ran into an error: The app returned "The resource could not be found.".

Userlevel 1

Hi Team,


I am getting some kind of a strange issue while trying to do a Find File in OneDrive.


I get the below message whenever I try to search for a file that does not have “testing” in the file name. If I use “Testing” followed by any other word, then it works. However, when I use the actual name of the file, it does not find the file. The file is same, it has the same level of access and owner is the account that is connected to the Zap. The file name is becoming an irritant for me. Could you please help resolve.


Failed to find a file in OneDrive

While requesting "dev_method" from OneDrive we ran into an error: The app returned "The resource could not be found.".

15 replies

Userlevel 7
Badge +14


Good question.

We will need to see detailed screenshots with how your Zap steps are configured along with the encountered error, thanks.

Userlevel 1

Sure @Troy Tessalone ,


Here is what I have; this time it is more wierd… I always get the file named testing (irrespective of the file name I am searching for)...


Searching for file with the name “testing



Test Successful.


Searching for file with the actual file name



Still getting the Testing file in return.




So I deleted the “testing” file from my OneDrive folder and then tested again. Got the below error.



Nothing is different except the file name. I can’t understand why would that play any role in search working and not working. Please advise.




Userlevel 7
Badge +8

@KPFS Hey there! 

Thank you for reaching out to us, I know this is probably very frustrating. I’ve done some digging on the back-end and this appears to be a bug. I say ~appears~ because we may need to test something out to confirm. Can you please try removing the “-” and spaces between words on your document? Perhaps rename to “KAFScheme1NKure”, less aesthetically pleasing, I know, but give it a shot and let me know if that ends up working out or not! 

Userlevel 1

@chanelle ,


Thanks for the suggestion. To be honest, I kind of tried those combinations (removing special characters), however, in the attempts that I have made; it only worked once while testing. Does not work in live zap.

Could I request to prioritize the fix. It is really important for us to have this feature working.




Userlevel 1

Also @chanelle , can you suggest a workaround; basically i have some PDF files in OneDrive that I want to attach to an email. The PDFs are named after individual lines in Airtable. So I want to find the file and then attach the relevant one to the email.


I tried using GDrive, did not work as I think it can only search for Google Doc and not PDF uploaded in GDrive…

Could you please suggest a workaround.

@Troy Tessalone 


Userlevel 4
Badge +6


Could you please check to see if there was some search restrictions that are only available for O365 business accounts?

Userlevel 1

Not that I can think of @Brem …

If it was about search restrictions, then it would not work even for Testing file. 


The wierd part is that is works for a specific file name and is inconsistent.


We are really at a final stage of deployment of a solution and eagerly looking forward to implement this. Could you please prioritize the fix and suggest a workaround in the meantime.




Userlevel 3
Badge +4


I understand this could be frustrating.

I have been doing some digging on this and I see that a few other users have been running into this problem. As it turns out, you've run into a known bug, unfortunately.
We already have a bug report in place so I've added your email address to the ticket. There doesn't seem to be a workaround, but we'll get back to you right away when a fix ships for this.
In the meantime, let me know if you have other questions. 😊

Userlevel 1

Hi @Charie and Team,


We are in another project requirement that needs this feature… Humble request to get this prioritized. It is very important (and seemingly basic) requirement to attach PDFs to emails based on a search result.


Let us know.

Userlevel 1

And to top it all, there is no workaround… we could have used a Google based solution… but it turns out, the Gdrive based search does not work on PDFs stored in GDrive, it only takes Google Doc files. In other words, if I create a Google Doc file, then I can use Google, otherwise not.


Please suggest if there is a way to keep PDF files in GDrive and then use a ZAP to attach those to an email in Outlook and Gmail.





Userlevel 7
Badge +12


I tested searching for a pdf file in Google Drive on my account and it did find one. The action I used was Find a File, I searched for a PDF in my Google Drive (ie not one shared with me/in a shared folder) and the Zap action successfully found the file. There aren’t any restrictions on the type of file that the Find File action will find, so I wonder if something else was happening when you tried it. 

Could I recommend giving Google Drive another try? Make sure that the pdf file you are looking for is in a folder that you own.  If that doesn’t work, it’s worth getting in touch with the Zapier Support Team on this one as they can take a closer look at your Zaps with you. 


​I hope that helps, please let us know if you have any questions!

Hi @Troy Tessalone @chanelle @Brem @Charie - Any update to this bug? I am getting same errors now on my zap. This is a zap that has worked correctly 1000 times before and even earlier today, so I’m not sure why it’s all of a sudden an issue. - Thanks


While requesting "dev_method" from OneDrive we ran into an error: The app returned "404 FILE NOT FOUND".

Userlevel 7
Badge +11

Hi @FrankP! 👋

Sorry to hear that you’re experiencing issues with the Find File (OneDrive) action as well. I’ve added you to the list of users so we can notify you by email the minute it’s been reported as solved.

In the meantime, it sounds like this issue is occurring intermittently so I’m wondering if replaying any errored Zap runs a little while later might then allow them to go through successfully? Can you please give that a try and confirm whether that clears the error?

It continued through the day but then fixed itself later on without any action on our part.

Userlevel 7
Badge +12

Hi @FrankP 

Thanks for letting us know, and I’m sorry you ran into this issue. If you do run into more trouble with this, please do let us know. Starting a new post/question is the best way to do that -we’ll catch your message quicker. 

Thank you!