Best answer

Failed to create an upload file in Google Drive The app returned "Not Found".

  • 27 June 2023
  • 8 replies
  • 148 views

I have had success with this same thing using Gravity forms but need to switch to Jotforms and of the same thing. all my steps are working except for the upload file to google drive from the jotform form. I keep getting the message 

Failed to create an upload file in Google Drive

The app returned "Not Found".

 

icon

Best answer by Troy Tessalone 27 June 2023, 05:38

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @keonacarr 

Good question.

You likely need to change the Jotform account settings.

Settings > Security > Privacy > Require log-in to view uploaded files (uncheck)

 

Thanks that worked!

Userlevel 1
Badge

Do all three fields need to be unchecked? And does this leave all of the submissions to my entire Jotform account open to anyone to see?

Userlevel 1
Badge

Sorry - meant to include this screen shot from Jotform: 

 

Userlevel 7
Badge +14

@CharlieZ 

Try adjusting only this setting.

 

Userlevel 1
Badge

Answered my own question through trial and error… it appears that it is just the uploaded files option that needs to be unchecked. A little disappointing that this might open up ALL uploaded files for ALL forms, but that’s a Jotform account, I guess. 

Still, wouldn’t it make sense that if the Zapier and Jotform accounts are “secure partners” this shouldn’t be necessary?

 

 

 

Userlevel 7
Badge +14

@CharlieZ 

Feedback and feature requests can be submitted via a ticket to Zapier Support to be properly logged: https://zapier.com/app/get-help

Userlevel 7
Badge +14

@CharlieZ 

Zapier is pulling the file URLs from Jotform which are governed by the Jotform Account settings, which is different from Zapier pulling the file object (temp file).