Best answer

Failed to create an upload file in Amazon S3. S3ResponseError: 400 Bad Request.

  • 8 January 2024
  • 5 replies

Userlevel 1

I am trying to transfer Google Drive files from a folder into an Amazon S3 bucket. I have linked to the correct Google Drive account and Folder, selected the ‘Upload File’ event through Amazon S3, linked to the correct S3 account and then set up my actions. For this, I linked to the correct S3 bucket that I would like to upload to. For the key, I have selected the title, for the file I have selected the file, and for mimetype I have currently selected none. I have gone to test the step and I get given this error: Failed to create an upload file in Amazon S3. S3ResponseError: 400 Bad Request.

Does anyone know why I got this error and how I can solve it? So far, I have tried putting in my AWS access key ID and secret access key details again, and re-tested to no success, and also tried setting the mimetype to text/csv.

Any help would be greatly appreciated!


Best answer by dannyfowler 12 January 2024, 11:29

View original

5 replies

Userlevel 7
Badge +14

Hi @dannyfowler 

To give us full context, please post detailed screenshots with how your Zap steps are configured along with the encountered error.

Userlevel 7
Badge +14


S3 help:


I Can't Add to a Specific Bucket (400 error)

Is your bucket in a different region than the one you selected when connecting your S3 account to Zapier? If so, you will need to reconnect and select the matching region.

Note that often (depending on the security policy of the S3 account you have connected to Zapier), we are able to see buckets from regions other than the selected region, but we are not able to interact with them. For example, if you have a bucket in US East (Ohio) (which is us-east-2), you may be able to select that bucket in a drop-down, but if you selected us-east-1 when you connected your account, we won't be able to upload files to that bucket.

AWS has documentation on their region names here if you aren't sure which numerical region your bucket resides in:

If you are still having trouble after this, please drop us an email so we can troubleshoot further with you!

Userlevel 7
Badge +11

Hey there @dannyfowler. Welcome to the Community! 👋

Just wanted to check in to see how you’re getting on with this. Were you able to get rid of the error using the information from the help guide that Troy shared? 

Let us know if you’re still in need of some help with this at all!  

Userlevel 1

Hi Sam,

Yes I managed to get past the error in the end. It came from having region set as default, and it was automatically setting the region as one that did not work with my data. All sorted now, thank you!

Userlevel 7
Badge +6

That’s great news @dannyfowler! Also, thank you for circling back for an update here.

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗