Question

Failed to create an encodefile in Base64 Encoder/Decoder

  • 20 January 2023
  • 1 reply
  • 62 views

I keep getting error code 502 when using this integration. I’ve tried reconnecting TheBase64 account, clearing the browser cache, using a different browser, and using a different account. I’m trying to convert file data to Base64 but I also tried converting just a string. Both don’t work.

It worked before but now I keep getting this error.

How do I fix this?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +11

Hi @ChrisBDesign, welcome to the Community! 👋

502 errors are often only temporary so it’s likely that it will working again if you try it a bit later. If its continually not working then you may want to reach out to our Support Team to investigate further. They’ll be able to dig into the logs for your Zap to see if we’re getting any additional info back from TheBase64 as to the cause of the error.

Aside from that, what you could also do is try using a Webhooks by Zapier action in your Zap. From what it says about the Rest API on the TheBase64 website it sounds like you’d use the Custom Request event and select POST as the Method. For the URL you’d use https://api.thebase64.com/encode and select the file data to be converted into the Data field. If the cause of the 502 error is on TheBase64 end then you may run into that error here as well. But at least it would confirm that there isn’t an issue with the file being converted or the setup of your current Base64 Encoder/Decoder action in the Zap.

Hope that helps. Please do keep up in the loop on how you get on here!