Question

Failed to create a subtask in ClickUp The app returned "Parent not child of list".

  • 17 October 2023
  • 7 replies
  • 149 views

Hi,

I received an order, triggered by an event, containing one or multiple items. When creating a task in ClickUp, I attempt to add subtasks to the parent task if there are multiple items.

Creating a single task works fine. However, when I try to create subtasks and associate them with the parent task, I receive the following error: "Failed to create a subtask in ClickUp. The app returned 'Parent not child of list'."

Please refer to the attached screenshots:
1. https://share.cleanshot.com/NrSMRrtW
2. https://share.cleanshot.com/yrwSCmbp
3. https://share.cleanshot.com/kxzymNdX

I use the same order number for the parent ClickUp tasks as the one used to create the first task.

Could someone please assist me?


7 replies

Userlevel 7
Badge +14

Hi @McRosbeef 

Good question.

In Step 8, the Parent Task likely expects the Parent Task ID from Step 4.

 

Hi Troy, thanks for the quick reply.

I forgot to mention that I tried using either the ID or Task ID, but I encountered the same error. I'm unsure of what to do next.

 

Userlevel 7
Badge +14

@McRosbeef 

We would need to see detailed screenshots with how your entire ClickUp Subtask Zap step is configured.

Make sure to map the ClickUp Task ID from a previous step.

 

@Troy Tessalone 

See below

 

Userlevel 7
Badge +14

@McRosbeef 

Check these field values.

Both fields expect integers or decimals, but the provided values don’t seem to be formatted correctly.

I will check. Maybe I didn't understand the loop preview well. It's my first time using it. 

From what I gather, the preview displays integers or decimals as loop values separated by commas. If I'm correct, the values should be correct, right?

If there is an error here, do you think it could cause the troubleshooting error "Parent not child of list"?

Do you have any clue why the ClickUp task ID is not recognized by the ClickUp subtask?

Userlevel 7
Badge +14

@McRosbeef 

Make sure you are testing with a ClickUp Task ID that still exists. (perhaps you deleted it)

 

Try removing those mapped values and testing again to determine if the same error persists.

If the error is resolved, then you know the issue is related to other fields.

If the error is not resolved, then you will need to continue troubleshooting.

 

Also, for those 2 fields I pointed out, those may have nested data for those data points or data in formats that aren’t properly handled by the Looping for Line Items.

Instead, you may have to try using Looping for Text. (I’d recommend duplicating your Zap before making this change to test.)

 

Make sure to carefully review the help articles for using the Looping app: https://zapier.com/apps/looping/help

You should NOT use the Looping variables that contain “Preview”.

 

Reply