Best answer

Failed to create a record in Adalo: The app returned "Forbidden"

  • 18 July 2023
  • 9 replies
  • 59 views

Userlevel 1

When I test adalo x zapier connection, it says connection successful, when i try to set up a zap to trigger an update in my adalo records for “calendar events” after a new calendar event is created on google calendar, when i hit test, it gives me the error: “Forbidden”. the adalo x zapier connection says it works, and I am using the right owner/admin account, it just wont work properly without throwing an error.

icon

Best answer by SamB 25 July 2023, 15:03

View original

9 replies

Userlevel 7
Badge +14

Hi @dan110 

Good question.

We would need to see screenshots with how your Action section of the Zap step is configured.

 

Userlevel 1

Hi @dan110 

Good question.

We would need to see screenshots with how your Action section of the Zap step is configured.

 

 

Userlevel 7
Badge +14

@dan110 

You may need to adjust the expected format of the Dates.

Often apps want the ISO format.

 

The ISO 8601 format for timestamps is as follows:

YYYY-MM-DDTHH:MM:SS.sssZ

Where:

  • YYYY represents the four-digit year.
  • MM represents the two-digit month (01-12).
  • DD represents the two-digit day of the month (01-31).
  • T is a delimiter that separates the date from the time.
  • HH represents the two-digit hour in 24-hour format (00-23).
  • MM represents the two-digit minute (00-59).
  • SS represents the two-digit second (00-59).
  • sss represents the milliseconds (optional).
  • Z indicates the time zone. "Z" represents Zulu time (UTC), and it can be replaced with an offset such as "+hh:mm" or "-hh:mm" to represent a specific time zone.

For example, "2023-07-18T14:30:00Z" represents the timestamp July 18, 2023, at 14:30:00 UTC.

 

 

Userlevel 1

@dan110

You may need to adjust the expected format of the Dates.

Often apps want the ISO format.

 

The ISO 8601 format for timestamps is as follows:

YYYY-MM-DDTHH:MM:SS.sssZ

Where:

  • YYYY represents the four-digit year.
  • MM represents the two-digit month (01-12).
  • DD represents the two-digit day of the month (01-31).
  • T is a delimiter that separates the date from the time.
  • HH represents the two-digit hour in 24-hour format (00-23).
  • MM represents the two-digit minute (00-59).
  • SS represents the two-digit second (00-59).
  • sss represents the milliseconds (optional).
  • Z indicates the time zone. "Z" represents Zulu time (UTC), and it can be replaced with an offset such as "+hh:mm" or "-hh:mm" to represent a specific time zone.

For example, "2023-07-18T14:30:00Z" represents the timestamp July 18, 2023, at 14:30:00 UTC.

 

 

I changed the fields to what you said and tested with all the different options, still the same error

Userlevel 7
Badge +14

@dan110 

Adalo help article: https://help.adalo.com/integrations/zapier

 

Please make sure that you are using the Zapier account of the owner (admin) of the Adalo application.
This is a security feature and Zapier <> Adalo would authenticate this connection, failing which your Zap would not work.

Userlevel 1

@dan110

Adalo help article: https://help.adalo.com/integrations/zapier

 

Please make sure that you are using the Zapier account of the owner (admin) of the Adalo application.
This is a security feature and Zapier <> Adalo would authenticate this connection, failing which your Zap would not work.

The zappier account and the adalo account have the same email, and It is the admin (owner) account, that isn’t the issue, its still giving me the same message

Userlevel 7
Badge +11

Hi there @dan110! 👋

Hmm, if the Adalo account that’s connected to the Zap is definitely the owner of the Adalo application then it may be best to reach out to Adalo’s support team about this. They developed and maintain the Adalo app on Zapier so they’ll better able to investigate why there’s still a “Forbidden” error appearing despite the permissions for the Adalo account being correct.

Please do keep us in the loop on how you get on with them, would love to know what the cause of the error is!

Userlevel 1

I could of sworn I had the admin account but apparently not, after talking to the adalo support team they helped me out and turned my account into the admin account, it really was the issue all along but the adalo team was very helpful

Userlevel 5
Badge +7

Thanks for letting us know @dan110 - happy to hear the issue is solved :) 

Reply