Failed to create a prompt in OpenAI

  • 23 January 2023
  • 7 replies

Hi there, 

I’m trying to connect zapier to gmail using the Zapier template. In step 2, I go to test the action and the error message is:

Failed to create a prompt in OpenAI
You exceeded your current OpenAI API quota, please check your OpenAI plan and billing details.

I’ve upgrade my OpenAI plan and they seem to think the account is fine. 

Any advice/help is appreciated!

Thank you :) 

7 replies

Userlevel 7
Badge +12

Hi @Darren Law!

That sounds frustrating, let’s see if we can get any further with finding a solution. I looked at Zapier’s notes for the OpenAI integration and there’s nothing there that describes what you’re seeing. My first recommendation would be to:

  1. Make sure that you’re using the most up to date version of the OpenAI integration
  2. Re-connect your account in Zapier

If that doesn’t work, it’s probably best to get back in touch with the Zapier Support team again. If you explain what OpenAI said and what else you’ve tried, they will dig into things for you. 


​I hope that helps, please let us know if you have any questions!

Userlevel 7
Badge +9

Hey @Darren Law! Also popping in here to share that I found this reddit thread where folks are discussing the possible cause of getting this message along with some potential workarounds to try:

Thank you Jesse! 

A lot of people seem to be in the same boat. I have tried most of those workarounds to no success unfortunately!

Userlevel 7
Badge +14

Hi @Darren Law 

TIP: Keep an eye on the OpenAI Status Page:

It can help make you aware of ongoing incidents, which may be impacting the Zaps.


Thank you for replying. I did both of those unfortunately and no joy as yet!


@Troy Tessalone Thanks for replying! 

I had a look and not a know issue I suppose (as far as outages/issue being logged). They made mention of API loading previously though so yeahhhh. 

I will revisit it tomorrow and maybe start from scratch again. Thank you!

Userlevel 7
Badge +14

@Darren Law 

If you still need help, it’ll be helpful to provide screenshots of how your Zap steps are configured along with any encountered errors in order for us to have full context, thanks.