Best answer

Failed to create a post in WordPress: Error code 403: Sorry, you are not allowed to assign the provided terms.

  • 2 December 2023
  • 6 replies
  • 203 views

Userlevel 1

I have a simple two step Zap that worked well several months ago when we last used it.

The first step is New Event in Google Calendar. (This step tests fine)
The second step is Create Post in Wordpress.

However it is now returning a 403 error on the second step:

Failed to create a post in WordPress

WordPress ran into an issue. Error code 403: Sorry, you are not allowed to assign the provided terms.

Here is everything I’ve done to troubleshoot:

  • Disabled security plugin
  • Checked hosting for any security measures or obvious red flags in the logs
  • Disconnected and reconnected my Wordpress credentials in the second step
  • Used the beta AI troubleshooter to supply me with any new information (nothing new there)
  • Searched the community and help guide for anything I’m missing 

And yes, my Wordpress login is an administrator, so that’s not the issue.

I did notice that the Zapier plugin, which Zapier says is required for the REST API connection, hasn’t been updated in 2 years. All the recent reviews are 1 star, saying it doesn’t work. Maybe this is the issue?

I manage several Zaps across multiple other Zapier accounts, and this is such a simple Zap, and I’m really feeling at a loss here.

​​​​​​​Any help is appreciated!


 

icon

Best answer by Troy Tessalone 5 December 2023, 16:33

View original

6 replies

Userlevel 7
Badge +14

Hi @LakeO 

Good question.

To help us have full context, please post detailed screenshots with how your Zap steps are configured.

Userlevel 1

Thank you for responding!

So I just logged in and starting taking screenshots, and tested the second step, prepared to take a screenshot of the error...but then it went through?! So I guess this was a temporary issue? I wish I could tell my client what caused it, as I really don’t want this to happen in the future. It was an issue for several days.

If this does happen again, I’ll reopen this so we can address it while the error is happening.

Userlevel 1

@Troy Tessalone I’m just now trying to get everything run through this Zap, and immediately encountered the error again. I believe I may have inadvertently tested an old record, one that had already successfully gone through the Zap months ago.

I then noted that whenever I tried to select the correct calendar as the trigger, it would default back to the old name of the calendar when navigating away from the step. (The calendar name was changed at some point in the last couple of months.) So I suspected that maybe the calendar name change is the reason for all this.

I decided to create an entirely new Zap, with the same steps. The calendar name is sticking this time. However, I’m getting the error again. 

Any ideas?? I’ve attached screenshots.

Userlevel 7
Badge +14

@LakeO 

Tags field is a dropdown field that expects a Tag ID as indicated by the 123 icon.

You can see the ID for each Tag option when viewing the list of options in the dropdown list.

 

Userlevel 1

Thank you!!! That fixed it! Setting the tag up in that way used to work, so something must have been updated in that step. Thank you so much for your help!

Userlevel 7
Badge +6

That’s a fantastic news @LakeO! Big thanks to Troy for pointing you in the right direction!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Reply