When clients text me I zap the text to Slack so I'm notified. I'd like to use MS Teams instead of Slack, but setting up Teams seems to be more complicated because I keep getting this error message when I test the zap: Failed to create a message in Microsoft Teams - The bot is not part of the conversation roster. The troubleshooting tips don't help and instructions Microsoft gave don’t work. Zapier customer service tell me I need to install Zapier into MS Teams for zap to work, but that’s already done. I have attached screenshots. Can someone let me know what the issue may be?
Hi
No screenshots were attached.
Attached here! Zapier is installed and the channel that I’m trying to zap client texts from Casepeer to is public. I’m experiencing the same error message for Fireflies integration.
attachments did not upload.
Not sure what’s going on. The screenshots aren’t corrupted on my end, will try uploading again. But you really don’t need the screenshots to understand the problem. I’ve explained in my description the problem I’ve facing. The screenshots simply support what I’m saying.
Can you show screenshots with how your MS Teams step is configured in the Action section while in EDIT mode?
Help article to reference: https://help.zapier.com/hc/en-us/articles/21703233048589-Microsoft-Teams-error-the-bot-is-not-part-of-the-conversation-roster
Feedback from ChatGPT
OBSERVATIONS
- You’ll want to put a space between the variables for first/last name.
- You’ll probably want to add static labels for each of the lines to give context.
- e.g. Name: Client_First_Name] _Client_Last_Name]
Is this a private channel?
Symptoms
You used the Send Channel Message action to send a message to a private channel and see the error "the bot is not part of the conversation roster." This error can appear in the Zap editor or Zap history.
Causes
This error happens because bots cannot be added to private channels.
How to fix it
You can bypass this limitation by emailing the private channel's email address. This will post your message to the channel. To do this, follow these steps:
- Check if you have the feature to send email to a channel. This feature must be enabled by your IT administrator in Microsoft Teams. If it's not enabled, you will not be able to proceed with the remaining steps. Learn more about how to send an email to a channel in Microsoft Teams.
- Use a Send Email action. In your Zap, replace the Microsoft Teams action with the use a Send Email action (using any email app). Zapier supports many email apps.
- Setup your Send Email action. Enter the channel email address provided by Microsoft Teams in the "To" field of the Zap action. This will post a message to your private channel.
Hi
I did some digging, and it seems that this error can occur when a Zap is trying to post to a private channel. Could that be the case here? If so, at this time, it isn't possible to post to a Private Channel.
Please keep me posted.
Hey
I was having the exact same issue and just managed to resolve it:
- Make sure Zapier App is installed in MS Teams
- Go to Apps
- Search for Zapier and install the app
- Connect Zapier from Teams
- Go to the team where Zapier is supposed to send messages to and open its settings
- Go to the Apps tab
- Select + Add other apps
- Choose Zapier
- From the big blue dropdown, select “Add to a Team” (or Chat if you’d like)
- Allow Zapier bot to post messages to “General” channel
- Go back to Zapier and retest your workflow, it should work now
So for me, the problem is that Zapier bot needs to be manually added to the Team where it’s supposed to send messages to.
Please let us know if that resolved your issue - I hope it :-)
A happy New Year everyone!
Martin
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