Best answer

Failed to create a message in Microsoft Teams: The bot is not part of the conversation roster.

  • 2 December 2023
  • 17 replies

When clients text me I zap the text to Slack so I'm notified. I'd like to use MS Teams instead of Slack, but setting up Teams seems to be more complicated because I keep getting this error message when I test the zap: Failed to create a message in Microsoft Teams - The bot is not part of the conversation roster. The troubleshooting tips don't help and instructions Microsoft gave don’t work. Zapier customer service tell me I need to install Zapier into MS Teams for zap to work, but that’s already done. I have attached screenshots. Can someone let me know what the issue may be?


Best answer by Martin Blaha 2 January 2024, 12:48

View original

17 replies

Userlevel 7
Badge +14

Hi @caseyxav 

No screenshots were attached.

Attached here! Zapier is installed and the channel that I’m trying to zap client texts from Casepeer to is public. I’m experiencing the same error message for Fireflies integration. @Troy Tessalone 

Userlevel 7
Badge +14


attachments did not upload.


Not sure what’s going on. The screenshots aren’t corrupted on my end, will try uploading again. But you really don’t need the screenshots to understand the problem. I’ve explained in my description the problem I’ve facing. The screenshots simply support what I’m saying. @Troy Tessalone 

Userlevel 7
Badge +14


Can you show screenshots with how your MS Teams step is configured in the Action section while in EDIT mode?


@Troy Tessalone 

Userlevel 7
Badge +14


Help article to reference:


Feedback from ChatGPT

The error message "The bot is not part of the conversation roster" in Microsoft Teams typically indicates that the bot you're trying to interact with is not currently added or properly configured in your Teams environment. This can happen for several reasons. Here are a few steps you can take to troubleshoot and resolve this issue:

  1. Check Bot Installation: Ensure that the bot is correctly installed in your Teams environment. If it's a custom bot, verify that it has been deployed correctly.

  2. Permissions and Access: Confirm that you have the necessary permissions to add or interact with bots in your Teams environment. Sometimes, organization policies restrict the use of certain apps or bots.

  3. Add the Bot to the Team: If the bot is meant to be part of a team conversation, make sure it is added to the team. You can do this by going to the team, clicking on the '...' (More options) button, and then selecting 'Add a member' or 'Apps' to add the bot.

  4. Check Bot Status: If it's a third-party bot, there might be an issue with the bot's service. Check the service status or contact the bot provider for support.

  5. Update Microsoft Teams: Sometimes, using an outdated version of Teams can lead to compatibility issues. Make sure your Teams application is up to date.

  6. Reinstall the Bot: If the bot was working previously and suddenly stopped, try removing and then reinstalling the bot.

  7. Consult IT Support: If you're unable to resolve the issue, it may be best to contact your organization's IT support team. They might have more insights into the specific configurations and policies in place.

  8. Developer Troubleshooting: If you are the developer of the bot, check the bot's registration in the Azure Bot Service and make sure the Microsoft Teams channel is properly configured.

If these steps don't resolve your issue, it may be helpful to provide more specific details about your setup and the bot you are trying to use for more targeted assistance.



  • You’ll want to put a space between the variables for first/last name.
  • You’ll probably want to add static labels for each of the lines to give context.
    • e.g. Name: [Client_First_Name] [Client_Last_Name]


@Troy Tessalone Thanks Troy, I’ve already read that article and others. I’ve already attempted the steps in the breakdown that chatgpt provided you. No resolution found.

Userlevel 7
Badge +14


Is this a private channel?



You used the Send Channel Message action to send a message to a private channel and see the error "the bot is not part of the conversation roster." This error can appear in the Zap editor or Zap history.



This error happens because bots cannot be added to private channels. 


How to fix it

You can bypass this limitation by emailing the private channel's email address. This will post your message to the channel.  To do this, follow these steps:

  1. Check if you have the feature to send email to a channel. This feature must be enabled by your IT administrator in Microsoft Teams. If it's not enabled, you will not be able to proceed with the remaining steps. Learn more about how to send an email to a channel in Microsoft Teams.  
  2. Use a Send Email action. In your Zap, replace the Microsoft Teams action with the use a Send Email action (using any email app). Zapier supports many email apps.   
  3. Setup your Send Email action. Enter the channel email address provided by Microsoft Teams in the "To" field of the Zap action. This will post a message to your private channel.



@Troy Tessalone No, it’s not a private channel.

Userlevel 7
Badge +14


You can try opening a ticket with Zapier Support:

@Troy Tessalone I already did that. Thought I’d reach out to the community to see if I could get additional assistance. I see you’re a zapier expert. What’s your specific expertise?

@Troy Tessalone Nevermind. I just checked your bio.

@caseyxav , have you solved your issue? I also have such issue and don’t know how to solve it. 

Userlevel 7
Badge +6

Hi @EveYu,

I did some digging, and it seems that this error can occur when a Zap is trying to post to a private channel. Could that be the case here? If so, at this time, it isn't possible to post to a Private Channel.

Please keep me posted.

Userlevel 1

Hey @caseyxav @EveYu,

I was having the exact same issue and just managed to resolve it:

  1. Make sure Zapier App is installed in MS Teams
    1. Go to Apps
    2. Search for Zapier and install the app
    3. Connect Zapier from Teams
  2. Go to the team where Zapier is supposed to send messages to and open its settings
    1. Go to the Apps tab
    2. Select + Add other apps
    3. Choose Zapier
    4. From the big blue dropdown, select “Add to a Team” (or Chat if you’d like)
    5. Allow Zapier bot to post messages to “General” channel
  3. Go back to Zapier and retest your workflow, it should work now


So for me, the problem is that Zapier bot needs to be manually added to the Team where it’s supposed to send messages to.

Please let us know if that resolved your issue - I hope it :-)

A happy New Year everyone!


Userlevel 1

@Martin Blaha that solution worked for me. I had to be an owner of the group, though, to be able to add Zapier to it. Thanks so much!