Question

Failed to create a lead in Zoho CRM: Unable to convert lead error: The HTTP request method type is not a vaild one.

  • 20 June 2023
  • 4 replies
  • 149 views

 


4 replies

Userlevel 7
Badge +6

Hi there @KASHISH,

Welcome to the Community! 🎉

Before we dig deeper into this, could you kindly share a full screenshot that displays all the fields under the "Action" section of your Zoho CRM step? Here's an example of what I'm looking for:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

This will help us get a clearer picture. The error might be due to some data mapping that expects a specific value.

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks! 😊

I’m attempting to connect zapier with zoho and tiktok to get leads populated in zoho.

 

I am only collecting phone numbers.

 

What do I put in these other fields? No matter what I put i get the same error message when testing the action.

error message below:

“Failed to create a lead in Zoho CRM

Unable to convert lead Error : Invalid data for the field id”

Other notes: I have zero leads on tiktok if that matters.
Userlevel 7
Badge +6

Hi there @bdr11233222,

I noticed the error in the screenshot seems to be related to the mapped data on the "Lead" field. This field specifically looks for the Lead ID in your Zoho CRM app. I recommend clicking on the "Or add search" button next to the "Lead" field. This action will add a new step to your Zap called "Find Module Entry." In this step, make sure to select the option "Create Zoho CRM Module Entry if it doesn't exist yet?" checkbox.

Once that's done, you can map the Lead ID from the "Find Module Entry" step to the "Lead" field in the "Convert Lead" step.

Hopefully, this helps! 😊

Instead of this method I went to - Ads.tiktok. com , clicked tools, then connect CRM button. This used a different method than what i was trying but works now. I give up on the first method. I also love how zapier doesn’t have a phone number customers can call. lol

Reply