Best answer

Failed to create a file in Dropbox The app returned "Not Found"

  • 10 October 2023
  • 7 replies
  • 122 views

Userlevel 1

I have created two zaps to help automate our POS Reporting process. The first one is functioning properly and begins when a new lead is created in our CRM, IRIS. Next a folder is created in Dropbox that is named based on the Lead ID. Then, a spreadsheet row is added to a google sheets that includes three columns: “Lead ID” is the Lead ID pulled from IRIS CRM, “Folder ID” maps the folder from Dropbox, and “Path” identifies the path to the correct folder in Dropbox. This Zap runs fine.

The second zap is triggered when a JotForm is submitted where a merchant uploads their POS Report. From here, we look up the correct spreadsheet row in the google sheet via the Lead ID from the JotForm submission. Then, ideally, we upload the report submitted to the correct Dropbox folder and then upload this to IRIS CRM to the correct Lead. 

We are running into an error when we try to upload the file to Dropbox. It says “Failed to create a file in Dropbox The app returned “Not Found.”

Do you know what could be causing the problem? Thanks in advance!

icon

Best answer by ken.a 12 October 2023, 12:42

View original

7 replies

Userlevel 7
Badge +14

Hi @FP_Caroline 

Good question.

To help us have context, please post detailed screenshots with how your Zap steps are configured along with the encountered error.

Userlevel 1
Zap 1 that works well
Zap 2 where encountering error
This is where the action is specified. The path specified is to the correct Dropbox folder.
What it says while the test is running
The error.

 

Please let me know if you need more information.

Userlevel 7
Badge +6

Hi there @FP_Caroline,

I’m jumping in to see if I can help!

I noticed something that might be causing the hiccup. It seems the mapped data in the “File” field of the “Upload File” step might be the culprit. Can you check if this data is a direct download URL or if it's a link to a publicly accessible file? For the Zaps to send files smoothly, the Zaps prefer either the file object or a direct download URL.

More about that here: https://help.zapier.com/hc/en-us/articles/8496288813453-Send-files-in-Zaps

Additionally, if you click on the URL and the file starts downloading immediately, that's a direct download URL.

Please keep us posted! 😊

Userlevel 1

Hello! Thank you for that article. That URL that is provided by Jot Form to Zapier is not publicly accessible nor a direct download. When a merchant submits their report via the Jot Form, it is stored in Jot Form as an .xls file. Do you have a suggestion for how do get these excel reports from Jot Form to the correct Dropbox folder? 

Userlevel 7
Badge +6

Hi @FP_Caroline,

If the value that's added in the File field doesn't lead to a file object then this could cause an issue. This might be happening because of specific behavior with this integration where JotForm is trying to protect your data and as a result, causes this error. If that's what's happening here, JotForm has provided the following workaround:

  1. Go into your JotForm settings and adjust your privacy preferences. Here's a link to do that quickly: https://www.jotform.com/myaccount/settings
  2. Once you're there, you'll need to make sure that "Require log-in to view uploaded files." is unchecked. This image will show you what that looks like:
    FD0A0BDA-D214-4270-B871-9054B8299F37.png
    (view larger)

After that, please load in a new sample data in the trigger step and use that new sample data and try testing the “Upload File” step again to see if it’ll work.

Could you please give that a try, and let me know how it goes? 😊

 

Userlevel 1

It worked! Thank you!

Userlevel 7
Badge +6

That’s excellent news @FP_Caroline! I’m glad to hear that it worked! 🎉

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Reply