Facebook pages are not appearing in the dropdown list for Facebook Lead Ads.

Hello, some Facebook pages are not appearing in the dropdown list.

We have all the necessary access and have also previously used those pages to zap Facebook Lead Ads. Not sure why only now are not able to see those Facebook pages.

5 replies

Userlevel 7
Badge +11

Hi there @Digital Symphony, thanks for joining our community! 🙂

If your permissions are all correct then it might be that you need to reset your permissions in Leads Access Manager. Often that can cause some issue and prevent the correct pages from being loaded. More on this here: The page I want to use is not showing in my Zap and in the Community article here:

Can you give resetting those Leads Access Manager permissions a try and let me know how that goes?

Hi Sam, we’ve tried removing the lead access and assigning it back again. The page still doesn’t appear. Is there anything else I can try?

Userlevel 7
Badge +9

Ah, thanks for that @Digital Symphony!

Apologies for backing up a bit here, is this a business page or account by chance? Facebook recently had some authentication changes so there are two different versions of the Facebook Lead Ads app. One for personal accounts and another for business admins. 

This is the setup process for the Facebook Lead Ads app (for Business admins) which requires these permissions:

Do I need special account permissions in Facebook Lead Ads (for Business Admins)?

  • The page that you’re connecting to must be part of a Business Manager account.
  • You must be an admin or manager of the Facebook Business Manager account you’re connecting. If you're not an admin or manager, you can use a different version of the Facebook Lead Ads app.
  • You need Admin or Manager permissions for the page and ad account you are trying to connect.

If all of these are good it might be worth just confirming the correct apps is selected in your zap. Let us know! 🙂

Hi @christina.d,

We have access to the Facebook page via business manager and have tried setting up the Zap through Facebook Lead Ads app (for Business admins). However, after everything is linked the following appears. Not sure why this has happened since the link was successful.



Userlevel 7
Badge +6

Hi there @Digital Symphony,

I’m jumping in to see if I can help!

This issue can happen even if you've given yourself all the permissions in Business Manager but have not assigned the page to all the categories in Zapier on your personal FB profile. 

Here are the instructions from Facebook: 

You'll need to make sure Zapier integration is active and all the permissions are enabled for it, like this: 
(view larger)

Can you please give that a try and see if that gets things working as you hoped? 😊