Question

Facebook Leads Ads to Mailchimp: "Email address is not valid" error

  • 27 October 2023
  • 11 replies
  • 56 views

HI,

I had a Facebook Leads Ads campaign set up. Initially, I wanted to send the leads to my Google Sheet, but it turned out to be impossible. So, I decided to skip that step and opted to send the leads to Mailchimp instead. The email address I'm trying to use is always the lead's email, and I've carefully reviewed everything.

I recently noticed that there might be a mapping issue, which is causing me some trouble. No matter what changes I make, I keep receiving an error message saying that the email address is not valid. 

If anyone can help me with this issue before I decide to cancel my account, I would greatly appreciate it.


11 replies

Userlevel 7
Badge +14

Hi @JUDITHESCOT 

Good question.

Please post detailed screenshots with how your Zap steps are configured and the encountered error to help give us more context.

Thank you! 

I believe the problem is at the email level. I’ve removed it, used mailchimp email code, nothing works. When I I keep the email as it is, its telling me my zap is ok. All emails sent to mailching have the same address

 

 

 

 

 

 

 

Userlevel 7
Badge +14

@JUDITHESCOT 

We would need to see how you have this Mailchimp Zap step configured with the dynamic variables mapped from Step 1.

 

@Troy Tessalone 

I'm not entirely sure if you're referring to a specific step. Are you asking about a step in the Facebook setup or the initial step to link the Mailchimp account?

Userlevel 7
Badge +14

@JUDITHESCOT 

We need to see screenshots with how you have your Step 2 configured in the Zap for Mailchimp.

Here’s all the screenshots, hopefully it will help!

 

 

 

Userlevel 7
Badge +14

@JUDITHESCOT 

The 2 screenshots don’t show any dynamic variables mapped from Step 1.

Help article to reference: https://zapier.com/help/create/basics/set-up-your-zap-action

Also, you have static values set for some of the fields shown in the screenshots.

Those static values should be REMOVED.

 

IM GIVING UP 12 HOURS LATER. FOLLOWED EVERYTHING YOU SAID AND LEADS ARE STILL NOT AUTOMATED

 

THANKYOU

Userlevel 7
Badge +14

@JUDITHESCOT 

We would need to see updated screenshots with how your Zap steps are configured.

@Troy Tessalone what is funny, when I performed a test all goes well but no leads get to my mailchimp automatically. Now I performed a test on all leads so they can get to my mailchimp anh having the process on,, 

 

 

 

 

Userlevel 7
Badge +14

@JUDITHESCOT 

Check your Zap Runs history details to see the DATA IN/OUT for each Zap step to help you troubleshoot.

https://zapier.com/app/history/

FYI: You may want to set this field to False.

 

Reply