Best answer

Error when looping through Google Sheet CSV, "Required field "Values to Loop" (loop_values) is missing."

I’m attempting to loop through a CSV of ticket IDs to add tags to tickets in Zendesk. I’ve been partially successful. 

Despite having 188 unique ticket IDs, I’m only able to loop through 58 of them before I get the error “Required field "Values to Loop" (loop_values) is missing.”

I haven’t been able to figure out why it’s hitting this error before having tagged all the tickets represented in the CSV.

Thanks for any help you can give!


Best answer by MatthewC 18 April 2022, 20:22

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

10 replies

Userlevel 7
Badge +14

Hi @MatthewC 

Good question.

Please post detailed screenshots with how you have your Zap steps configured with the variables mapped between Zap steps in order for us to have more context, thanks.

Thanks @Troy Tessalone ! Here’s a more detailed description. Thanks again for any insight you might have.


Here’s the overall view:


Step 1:


Step 2:

and here’s the link to the public google sheet for reference:


Step 3:



Step 4:



Userlevel 7
Badge +14


Are there any gap rows w/o data?


Not that i’m able to see. I’ve also tried loading the data as a CSV directly rather than reading from a Google Sheet.

Userlevel 7
Badge +12

Hi @MatthewC,
What is the output from step 2 in your Zap History? Is that a public file for Zapier to read? If not, you will need to pull the file back with a Google Drive step before importing it into the utilities step. 

The output is a Google Sheet published to the web as a CSV. I also tried uploading a CSV directly to Zapier and accessing it from a local file. Any other options?


Userlevel 7
Badge +14


Best place to troubleshoot is the Zap Runs where you can see the DATA IN/OUT for each Zap step to help get a better sense why something caused an issue/error:

It seems that the Data out is what i’d expect. It gives an uninterrupted output of ticket IDs and I can’t find any blanks or malformed data or anything.


Userlevel 7
Badge +14


Can you post detailed screenshots with how your Formatter Zap step is configured?

I think i fixed it! I removed the header row in the Google Sheet and set “Force first row as header row” to “No”. Thanks everyone!