Question

Error from halted execution: The provided image does not appear to be valid.

  • 13 February 2023
  • 6 replies
  • 691 views

I am trying to connect a coda table data with Buffer to schedule my posts. Everything is working fine but when I run the zap, it gives the error as “ Error from halted execution: The provided image does not appear to be valid. ”. Can anyone help in resolving this? Attached is screenshot


6 replies

Userlevel 7
Badge +11

Hi @Steven Rudolph! 👋

Buffer will need to have either a file object or publicly-accessible URL to the file selected. If you need to login to view the image then the Zap wouldn’t be able to access it, which might be what’s causing that error. You can find out more about send image files between apps here: Send files in Zaps

What is Buffer using for the image? Is it trying to use an image that’s embedded in a Coda? Or does the Coda doc contain a link to the image file which is being passed over to Buffer? Looking forward to your reply!

Hi Sam, thanks for your quick reply. PLease note that we are using image url for the image. We also tried to use an image type field in the coda table but that also didnt work. PLease see the screenshot. The url that we are using is directly accessible from the web. we used https://uploads-ssl.webflow.com/5f27847399dc5d45c9b8fbbc/5f6ef224d8a2314f8d8fda67_Older%20Female%20Counselor%20short%20white%20hair-p-1080.jpeg and also

And

 but it didnt work.

 

So please suggest

Waiting for a solution from someone who has faced this issue

Userlevel 7
Badge +11

Thanks for confirming that @Steven Rudolph. 🙂

The Google Drive share link would have linked to a view of the image, not the image file itself. So that would be why that link wouldn’t have worked. What’s weird is that the other image link you tried should have worked though as it’s a publicly accessible link to the image file. 

Can you share a screenshot showing the set up of that Buffer action in the Zap with that URL to the file (not the share link selected)? Please remember to remove or hide any private information like names, emails etc. from it first. 

Hoping that screenshot will help us to get a better idea of whether Coda is sending the full URL to the file through to Buffer. I’m wondering if the URL that comes from Coda is changed or truncated in someway that’s preventing Buffer from using it to access the image. Do you think that could be the case?

Hi Sam,

There is a small update from here. The zap seems to be working fine with the second image link now. ACtually the problem I am facing is that when I setup the coda settings and reach to the last step to test the working of coda actions then I have to choose a record in this step (as shown in 1.png screenshot)

Then when we test the action for the buffer thing it takes value of that record only and the test works fine in that case. The problem is that when I am adding new row in coda it does not get updated dynamically in the zap and it remains the same. How do I make the zap to take dynamic values after every few minutes

PLease check 2.png for buffer actions

. DO let me know if you need any other info.

Userlevel 7
Badge +11

I’m so pleased to hear that image is working now @Steven Rudolph! 😁 

Ah, I think I’ve spotted the issue here. It appears the Zap is using Updated Row trigger, which would mean it would only trigger for existing rows that are updated. So that would be why the new rows are being missed.

You’d need to switch it to use the New Row trigger instead. That would allow the Zap to trigger for new rows that are added to the Coda doc and send the relevant information over to Buffer. 

Can you give that other trigger a try and let us know if that gets it working?

Reply