Question

Error: failed to fetch a reaction in Slack, error while retrieving mime: mimetype

  • 24 January 2023
  • 3 replies
  • 32 views

Userlevel 1

So, I’ve seen a few questions regarding this topic which say it is resolved.

When I try to set up New Reaction Added in Slack the program doesn’t let me find any samples when the User field is filled out with my name. When I let a colleague react in the channel, and filled out his name in the user field it found a sample. I build the zap with the tasks it needs to do, but eventually when I wanted to use the Zap, it didn’t work. Tried the Custom and the pre-set emojis with and without colons. I’ve tried to keep the option user open as well, to let anyone that reacts the emoji trigger the zap. 

What I eventually would like is that, the messages send in the public channel which get the emoji are send to Asana and a ticket is created. With the test of the whole zap it ended up where it needed to be, after that; nothing.

Hopefully one of you can help me!

 


3 replies

Userlevel 7
Badge +14

Hi @Facco 

Good question.

Can you please link to the other topics you reference which say the issue was resolved?

 

My triggers aren't picking up the messages I need

If your message is preceded by an indentation, it’s a message attachment, not a message.

Slack Message Attachment Example

Message attachments are usually sent by bots, slash commands, or other Slack integrations. Your Zap can’t trigger from message attachments.

 

Triggers aren’t returning samples

If the New Mention, New Message Posted to Channel, or New Message Posted to Private Channel triggers aren’t returning any samples when testing:

  • You must enter either a user name or highlight word.
    • If both are entered, the user name and highlight word must be included in a message to trigger the Zap.
  • You must create a sample message in the #general channel that includes the user name and/or highlight word.
    • Once you turn the Zap on, it will look for the mention in all public channels, or the specific channel you select.
  • By default, only user messages will be returned as samples when you test your Zap.
    • To trigger from bot messages, you must select "Yes" from the dropdown menu in the Trigger for Bot Messages? field.
Userlevel 1

Hi @Troy Tessalone

Thank you for the response! Now, the sample was found when I retrieved it using the username of a colleague that posted and reacted on a message in the public channel I created. (Somehow it does not find it when I would do it myself.) I worked out the path for the task after the trigger and the test worked. The zap is meant to export questions posted on slack and create a task in Asana. However, when I published the zap and put the reactji on another question it did not execute the process. I checked history and it does not mention any task, failed or succeeded. 

The messages are not preceded by an indentation :)

Any thoughts?

Userlevel 7
Badge +14

@Facco 

You may want to try opening a ticket with Zapier Support for further assistance in troubleshooting the issue: https://zapier.com/app/get-help

Reply