Best answer

Error: Failed to fetch a form entry from WPForms Error while retrieving: JSON results array could not be located

  • 10 January 2023
  • 5 replies
  • 746 views

Userlevel 1

Hi, 

 

I’m new here and trying to make a ZAP with WP forms (PRO) but i’m keep on getting an error: 

 

Failed to fetch a form entry from WPForms

Error while retrieving: JSON results array could not be located.

 

  • My accounts from WP-forms is PRO and from Zapier is Starter. 
  • I have downloaden and activated the Plug-in from Zapier on WP-site and connected it with the API key from (WP forms in WP-site) to Zapier. 

 

But when I try to test the trigger I keep on getting the error down below. 

 

 

What can i do about this? 

 

With Kind regard, 

 

Thomas from Bouwinspecties.com

icon

Best answer by SamB 11 January 2023, 14:18

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +11

Hi @Bouwinspecties.com! 👋🏻

I did some digging and apparently if the “Disable storing entry information in Wordpress” option in WP Forms is selected then we’re unable to fetch the form entry samples.

Can you take a look at the settings for WP Forms on your site and try unselecting that option to see if that fixes it? It should be located in Settings > General > Advanced in WP Forms.

Please do give that a go and let us know if that solves it!

Userlevel 1

Hi Sam, 

 

I’ve tried it but it didn’t work, see below: 

 

 

Do you have any other suggestions? 

 

With kind regard 

 

Thomas from Bouwinspecties.com

Userlevel 7
Badge +11

Thanks for getting back to us @Bouwinspecties.com! 🙂 

In your screenshot, it looks like that Disable storing entry information in Wordpress is still selected. It needs to be unselected, not selected. Sorry for any confusion caused here.

Can you try unselecting that option and report back? And you may also want to try reconnecting your WP Forms account after making that change to refresh the connection between the Zap and WP Forms just in case that’s a factor here. 

Userlevel 1

Hi Sam, 

 

It works😄, thank you very much for your input 😘. Disableling storing entry information in Wordpress is a default setting in WP. I think reconnecting WP forms and refreshing the connection between Zap and WP did it. Have a nice weekend. 

With kind regards, 

Thomas 

Userlevel 7
Badge +11

That’s awesome news, @Bouwinspecties.com! 🎉

Thanks so much for reaching back out here to confirm that reconnecting after disabling that Disable storing entry information in Wordpress option fixed it. I’m so glad it’s working now! 😁