Best answer

Error: Failed to create a task in Asana, The app returned Console logs: ` as error, which we cannot read.

  • 6 January 2023
  • 5 replies

Userlevel 1

Hi all!


I’m trying to build a Zap that will automatically update information in tasks in Asana for my team when a change is made in JIRA. However, I keep running into errors similar to this example when testing:


Failed to create a task in Asana

The app returned `{"message":"task: Not a Long: Report - create greg's sales reports "} What happened: Executing creates.update_task.operation.perform with bundle {"message":"task: Not a Long: Report - create greg's sales reports "} Console logs: ` as error, which we cannot read.


Everything on the JIRA side is testing out fine. On that note - does anyone know a best practice for updating JIRA statuses in Asana? I was able to pull them in to the creation of new tasks on a Zap that worked, however for updating existing tasks I don’t even see an option to update the JIRA Status field that I’ve created in Asana.


Thanks in advance!


Best answer by Troy Tessalone 6 January 2023, 19:59

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +8

Hi @James Day, since I’m not seeing this as a reported issue in our system I’d like to request you post screenshots of your Zap so we can have a closer look at the details? 


Additionally, for your second question I want to be sure I understand. Are you looking to have a Zap that triggers in Asana and the action occurs in Jira OR triggers in Jira and the action occurs in Asana? 

Userlevel 1

Absolutely Chanelle!


I’m looking to have a zap that triggers in JIRA and then the action occurs in Asana.


This is the portion of the Zap to update info in Asana, I’ve been leaving it pretty bare just to try to get it up and running.


And here is the actual error message:



Userlevel 7
Badge +14

Hi @James Day 

Good question.

The Task field expects the Asana Task ID, instead of the Asana Task Name, as indicated in the field description.


Userlevel 1

@Troy Tessalone that fixed it! Thanks so much for the help!


On my side note though - does anyone have any familiarity on how I could update the JIRA Status field I have in Asana from JIRA? I’m not seeing an option to push updates with that. Or is it something that isn’t available on the free version?

Userlevel 7
Badge +14

@James Day 

Can you please clarify your new question or perhaps post as a new topic and provide a specific example so we have enough context?