Best answer

Error during execution: Cannot read property 'id' of undefined

Userlevel 1

I'm working on integrating a zap for our Google Lead Form ads, I got the following error when testing and also when trying to transfer data.


Error during execution: Cannot read property 'id' of undefined


I have included a screenshot also.


I’ve been trying to test the form out on Google but am having no luck there, please help guide me in the right direction to get this resolved, thank you.


Best answer by SamB 25 September 2023, 17:54

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +6

Hi there @Tudi.Mechanical,

Welcome to the Community! 🎉

I apologize for the inconvenience caused by the issue with the Google Ads app integration in your Zap.

I did some digging into this, and it seems like you’re running into a known bug with the Google Ads integration. I have added you to the bug report so that we can keep you updated on the progress. Unfortunately, I cannot provide an estimated time for the resolution, but we will inform you via email once it is resolved.

In the meantime, you can use the workaround mentioned in this post:

I understand that this may not be the news you were hoping for, but please let me know if you have any other questions or concerns.

Userlevel 1

@ken.a So the form was working correctly after taking the suggestions mentioned above. We were getting customer form submission data and it was getting placed into our CRM (Hubspot), this was until a few days ago. Now, we’re not getting any customer form submissions (even though are showing within Google Ads that conversions have taken place) and now we’re getting testing submissions only, which are not coming from our end.

Do you have any ideas as to where the new issue has come from or any other possible solutions?

Userlevel 7
Badge +6

Hi there @Tudi.Mechanical,

Google Ads sometimes only provide “fallback” sample data. To get around this, I recommend following this Community post here: 

Hopefully, this helps! 😊

Why isn’t this fixed yet? 

Userlevel 7
Badge +6

Hi @gpbush,

I apologize for the frustration that this bug may have caused you, and I understand where you're coming from. Our current process for handling bugs might seem a bit "opaque," and I realize that can sometimes give the impression that not much is happening. But I assure you, that's far from the truth.

With over 5,000 different integrations on Zapier, our priorities are always on the move, and there are countless variables at play, some of which are beyond our control (like waiting for our partners to make changes). Because of this, it's tough to provide accurate timelines for bug fixes.

What I can tell you is that once a bug is reported, our team jumps on it and works diligently to resolve it as swiftly as possible. And of course, we'll keep you in the loop and let you know as soon as it's fixed.

In the meantime, I'm here, taking all your feedback and making sure it's heard so that we fully understand the impact of these issues.

I know this doesn't change the fact that you're waiting for fixes, but I hope it reassures you that we're doing everything in our power to resolve them as quickly as we can. Your patience and understanding are greatly appreciated! 

I am not frustrated by the “opaque” process.  It is frustrating that this is obviously something your company worked out with Google to support their platform, that this has been happening for some time, you still do not have a timeline to fix it, and you respond with a useless answer that justifies a total lack of support.

Using the excuse that you have over 5,000 integrations is really not that smart.  If you cannot support that many properly, you should not offer them as a paid service.  If you are offering them as a paid service without the intention of supporting them, then in the US, this would be fraud.  If you are a public company you could actually face criminal charges for fraudulently inducing investors for products that you say work but have no intention of making work.  

You also say it can be that you are waiting on the partner.  Are you?  ( I doubt it as Google has almost infinite resources.  Since Google Ads are a significant portion of their revenue, this would be a priority.)

Also, having been in software development for over 30 years,  if you were really working on this there would be some type of timeline, with at least what stage you are at, that could serve as a response instead of a condescending one that offers no useful information.

I would suggest that the person ultimately in charge of support open their eyes and stop encouraging this type of behaviour. 

I have been using Zapier since 2014.  While the application has expanded greatly, with responses like this, support has really gone to sh!t in my experience.

Userlevel 7
Badge +11

Hi there folks! 👋

Thank you all for your continued patience while this was being worked on. Just following up here to confirm that the bug report for this issue has recently been closed. So these “Cannot read property 'id' of undefined” will no longer be appear when testing in the Zap Editor. 🎉

If you find that you’re still running into those errors when testing your Zap, I’d recommend reaching out to our Support team with a recent example of the error and so that they can investigate further. You can contact them here: