Question

DynamoDb timestamp field not populating as an option

  • 12 January 2023
  • 3 replies
  • 15 views

Hi, 

I have added a Unix time stamp to DynamoDb but Zapier is not recognizing it.  Also, when choosing the custom option I am unable to.
 

Any help will be appreciated.

 


3 replies

Userlevel 7
Badge +9

Hey there, @ryanam6480! Thanks for reaching out in community.

I can see you commented here yesterday:

Bummer that value isn’t popping for you. 😔 I’m not super familiar with DynamoDB but just to make we’re covering our bases, is it possible to change the field type in your actual DynamoDB table to a “custom-modified” value and then retest the trigger? I wonder if that’s what it’s referring to.

Keep us posted if that’s an option! Definitely want to get to the bottom of this with you.

Hey there, @ryanam6480! Thanks for reaching out in community.

I can see you commented here yesterday:

Bummer that value isn’t popping for you. 😔 I’m not super familiar with DynamoDB but just to make we’re covering our bases, is it possible to change the field type in your actual DynamoDB table to a “custom-modified” value and then retest the trigger? I wonder if that’s what it’s referring to.

Keep us posted if that’s an option! Definitely want to get to the bottom of this with you.

Hi, No that did not work.  I am still looking into this thought.

Thanks

Userlevel 7
Badge +11

Hey @ryanam6480👋

From the look of that screenshot when you selected the Custom option, the ID (unique identifying number/name) for the UNIX timestamp field wasn’t entered. When using the Custom option in an action you can select a value from a previous action or trigger step. But when using the Custom option in a trigger you’ll need to type in the ID for the field or option you want to select: 
88ab8d5393a58883e2e2b28facde2127.png
Can you take a look in DynamoDB to locate the ID for the UNIX timestamp field you’re wanting to select here? Then type that ID into the Timestamp Field field. That should then allow the Zap to use that UNIX timestamp field. Please do let us know whether that solves it!

Reply