Best answer

Dropdown custom field in ClickUp is not transferring correctly to Google Sheets

  • 17 February 2023
  • 14 replies
  • 308 views

Userlevel 1

Hi, i’m having trouble to connect clickup to google sheets.

Whenever the custom fields is dropdown even if it’s been selected the value still shown 0

any one can help? much appreciated 

 

icon

Best answer by ken.a 31 October 2023, 10:33

View original

14 replies

Userlevel 7
Badge +14

Hi @Luthfi 

Good question.

For context, please post detailed screenshots with how your Zap steps are outlined and configured, thanks.

Userlevel 7
Badge +8

Hey there @Luthfi, hope you had a great week! Did you still need any assistance with this? We’d love to help you out if you do, please be sure to come back with some screenshots of your Zap setup so we can take a closer look. 😄

I’m having the same issue. I have dropdown values but it will only show numerical values (0,1,2,etc) based on the ordered list.

Userlevel 7
Badge +9

Hey there, @megan-mauto! Thanks for reaching out. 

Can you share some screenshots of the setup for this zap step with any personal details removed? That should help us troubleshoot with you.

Thanks!

I too am using Zapier to pull Custom Field data from a Dropdown field.

I need the term “Kosher Certification” to be used in other Zaps, but the Value that is easily pulled from ClickUp is “1” (which only refers to the order index associated with Kosher Certification). How can I get the term “Kosher Certification” without a complicated addition of steps like storage or tables?

 

Here is a clear view on how Zapier is pulling ClickUp data:

 

 

Userlevel 7
Badge +6

Hi there @philipio,

Unfortunately, I couldn’t figure out the cause of why this is happening with the custom fields on your ClickUp Zap. I recommend reaching out to our Support team so that they can take a closer look at the Zap and its logs to determine the cause of the issue.

You can reach our Support team here: https://zapier.com/app/get-help

Thank you for your understanding.

Having the same problem. The issue is that ClickUp is providing the INDEX of the dropdown value and not the LABEL of the Value. There is an array of all the LABELs provided by ClickUp. But there’s no field in Zapier to map the LABEL value. So it’s currently useless to try to send Dropdown values to Zapier. 

On another note, I wouldn’t have to do what I’m trying to do if ClickUp Formula custom fields would work with TEXT fields!!! 

Userlevel 7
Badge +6

Hi friends,

I did some digging into this, and it seems like the names of the custom fields are coming through but not their values. I have added you all as another interested members to the feature request. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track interest in this feature being implemented
  • Allows us to notify you via email if this feature becomes available in the future

While I don't have an ETA on when this feature might be implemented, we will notify you via email if it is!

Hopefully, this helps.

Userlevel 1

Adding my hat to the ring as someone affected by the inability to map the label of a dropdown in ClickUp. We have a lot of dropdown fields in ClickUp, so that severely limits our Zapier use cases there. Would be great to see this implemented at some point. 

Userlevel 7
Badge +6

Hi friends,

Just a little update here. I did a quick check here and it seems like one of our Support Team opened a bug report regarding the dropdown field with ClickUp issue. Here’s the description of the bug:

All of the drop down fields come through the Zap and show up as line items. The value that was chosen in the drop down comes through as an Index for the array of line items instead of the value chosen.

If there are 15 options, and the user chooses option 6, we're receiving the value: "6" instead of the chosen option's name.

I think this bug more inline than the feature request I mentioned earlier in this post. I apologize for the confusion on my behalf. That said, our team is aware of the issue and we're working with ClickUp on a fix. I have added all of you to the open bug report. While we can’t provide an exact timeframe for the bug’s fix. However, we will keep you in the loop via email once the bug has been fixed.

Thank you for your patience and understanding.

Can you add me to the list please - I am also trying to create a zap that needs the value / label of custom dropdowns used and displayed…
Beryl

Userlevel 7
Badge +11

Thanks for reaching out here, @berylp. We can’t provide an ETA on when this will be resolved but I’ve added you to the list so we’ll definitely be in touch as soon as a fix is shipped. 

@SamB please can you add me to whatever I need to be added to, to get notified on progress on this issue?

Userlevel 7
Badge +6

Hi @Colin_C_C,

I have added you to the bug as another affected member. We will keep you in the loop via email once the bug has been fixed.

I appreciate your patience and understanding

Reply