Question

Discord server dropdown is empty, cannot configure it.

  • 8 November 2023
  • 5 replies
  • 127 views

I’m trying to create a new Zap where if I get a new message in a Discord channel, it will send me an SMS text message. I create a new Zap and when I choose that trigger I get the Discord sign in pop-up. There I authorize it but in the “Select a Server” the dropdown is empty. Is there something I need to do in Discord for my servers to appear?


5 replies

Userlevel 7
Badge +14

Hi @enunz 

Good question.

Have you already reviewed these help articles?

https://zapier.com/apps/discord/help

Yes I have, none of those answer my specific question. Do you have a specific link that I missed?

Userlevel 7
Badge +6

Hi there @enunz,

I’m jumping in to see if I can help!

Before we dig deeper, could you please disconnect the Zapier bot from Discord. Like so:

Go to User Settings > Authorized Apps Then hover over Zapier and click on the Deauthorize button that appears:

After that, please also remove the Zapier bot in your server settings. Like so:

6944972af87808878f84768b8f0ad9ea.png
(view larger)

f6b899a939f012071599cced6cde3b46.png
(view larger)

92b30b5360105bce7f69e2096550fb20.png
(view larger)

f518ae03e41c71d07439fad00e26c857.png
(view larger)

After removing the Zapier bot in Discord. Could you please try connecting a new Discord account in Zapier via an incognito browser?

Please give that a try, and let me know how it goes!

Hello Ken, I don’t have Discord in my connected apps to remove. It seems I’m not able to integrate with it. Do I need any special server permissions to be able to have it alert me when new messages appear in a discord channel?

Userlevel 7
Badge +6

Hi there @enunz,

Here’s how I connected my Discord server to Zapier:

  1. I created a new connection in the Apps page here: https://zapier.com/app/connections/discord
  2. A new pop-up window will show up. Here’s what it looks like:
    363093d3dc48b0aad55ca2fb608e2031.png
    (view larger)
     
  3. After selecting the server and clicking on the “Continue” button, the permissions page will show up:
    adae8c39d6f900ee8dd27d54bf225414.png
    (view larger)

Are you seeing the same thing on your end? Please let me know!

Thanks!

Reply