Question

Discord Messages sending in wrong order

  • 10 January 2024
  • 10 replies
  • 110 views

Userlevel 1

So, basically, I have zaps to sending messages from one discord server to another - one zap per channel - and it works….some what. I’ve watched a youtube video on how to do this correctly, followed the steps and all, but the only issue is that when it copys the messages from one server to send it to the other - they’re out of order.

Hard to explain, but for example; I send a message, then my friend sends a message. What zapier does is then copys the messages to send them to the other server like i set it up to, but instead of sending my message first, itd send my friends. even though i sent it first. it doesnt matter how many messages i send it reads and sends them backwards.

How can I fix this?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

10 replies

Userlevel 7
Badge +6

Hi there @Stray,

Welcome to the Community! 🎉

Before we dig deeper into this, could you please try adding a 20-30 second delay to your Zap by using Delay by Zapier? You can learn more about Delay by Zapier here: https://help.zapier.com/hc/en-us/articles/8496288754829-Add-delays-to-Zaps

Please let me know if that works.

Userlevel 1

I guess I didn’t do it correctly, but I followed the link you sent and now the zap will not send at all.

Userlevel 7
Badge +6

Hi @Stray

Could you please send a screenshot of your Zap setup? Also, please send a screenshot of the “Action” section of your action steps that shows all of its fields. Like so:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks!

Userlevel 1

I hope these are alright.

Userlevel 7
Badge +6

Hi @Stray,

Thanks for the screenshot! However, it looks like the screenshot attached is incomplete. Could you please scroll up to the top and send a screenshot of that section as well?

Thank you!

Userlevel 1

Sorry, I had sent 2 attachments, I guess one didn’t go through. Is this what you need?

 

Userlevel 7
Badge +6

Hi @Stray,

Thanks for the screenshot!

It looks like there is no issue with your Zap setup. However, is there any error in the Zap History after the Zap runs? If not, could you please try doing a Zap cycle by turning on/off your Zap and reconnecting your Discord account?

Please keep me posted.

Userlevel 1

I did as you said, and they’re sending somewhat better. Usually in the same order. The only issue now is how it reads it from most recent message to least recent and sends them to the alt server in the opposite order. Is there a way I can fix this, or no?

Userlevel 7
Badge +6

Hi there @Stray,

Thanks for an update here.

My next recommendation would be is to reach our Support Team regarding this issue. They have the correct tools to look closer at the Zap and its logs to determine the cause of the issue.

You can reach our Support Team here: https://zapier.com/app/get-help

I appreciate your patience and understanding.

Userlevel 1

Thank you