Best answer

ClickUp error: Failed to create a task in ClickUp > The app returned "Value must be an option index or uuid".

  • 6 September 2022
  • 4 replies
  • 55 views

Userlevel 1

We would like to create a task on ClickUp after our clients submit their task in ManyRequests. Currently, we have connected ManyRequests and Google Sheet and mapped each fields to corresponding columns in the spreadsheet.

Next, Google sheet is connected to ClickUp and all columns are then mapped to existing ClickUp fields including custom fields. My problem is everytime I run and test the trigger/action, I always encounter an error stating that it Failed to create a task in ClickUp > The app returned "Value must be an option index or uuid".

I am relatively new to Zapier and I don’t know how to troubleshoot this error. Where could the error lie? from Manyrequests to G-sheet or G-sheet to ClickUp. I noticed that some data from ManyRequests when added on the Google sheet has a <div> tag in it. Example of this is the Description field. Could this be the reason for the error?

Any input you may have is highly appreciated. 

icon

Best answer by LauraP 6 September 2022, 16:26

View original

4 replies

Userlevel 3
Badge +2

Hi @Noel Morado! Thanks for the question.

This type of error usually appears in ClickUp when a dropdown field (like "Assignees", for example) has a set of defined options, and the mapped information doesn't correspond to the ID of one of those options.

 

Here's an example from a test Zap I created. In this case, The "Assignees" field has a set list of people that can be selected. The Zap needs the ID that appears under the name of the person, not the name itself. 

 

 

So, in this case, if the information coming from Google Sheets was the name "Wintson", then the Zap would show that error you're seeing, because it expects the ID, not the name. 

 

To check on your Zap, go through existing fields and check if any of them show an ID in grey, under the name of the option. This will let you know you may need to change the information that's sent to ClickUp!

Once you find that field, you could try a couple of different approaches:

  • If it's not a lot of options in the dropdown, you can add a Formatter step, using a Lookup table and match each option name to its ID.
  • If it's a large number of options, I would recommend creating a spreadsheet to save all IDs and names, and using an action like "Lookup spreadsheet row", to search for the ID that matches the specific option name.

 

Let us know if this matches what you are seeing in your Zap! 

 

Userlevel 1

Thanks, LauraP. does that mean I need to get in touch with ClickUp for the option IDs or I can just get it from the options presented in Zapier? There are only 10 items in the Task Type dropdown menu so I just add a Formatter step to resolve this error.

Userlevel 7
Badge +11

Hi @Noel Morado!

I see you reached out to our Support team and they helped you out :) You’d mentioned you would be reaching out to ClickUp to see how to get the IDs that you need.

Would love to hear if you’ve had any luck with that. If it’s something that you can access yourself, it could help others who are trying to find such IDs.

Thanks!

Userlevel 1

ClickUp was telling me to use their API etc. which is highly technical for me. What I did was to follow the instruction given by @LauraP. Zapier has the IDs for each dropdown menu. I created a look up table and copied the option IDs for each dropdown menu items. Run the formatter utilities and it worked.

Reply