Best answer

Cannot Publish Zap Google API Errors


Userlevel 1

When i try to publish a zap with either google forms or google sheets being the trigger, i am greeted with the Error message 
 

Specified authentication isn't for GoogleSheetsV2API
Specified authentication isn't for GoogleFormsCLIAPI@1.0.2

 

How do i fix this error and publish my zaps. There is nothing special happening. I have already tried to re make them, this does not work.

icon

Best answer by jesse 7 July 2022, 23:48

View original

17 replies

I’m also having this issue.

I have also just received this error message.

Also having issues. From the timestamps this is a new issue.

Same here

Userlevel 1

Me too, I am using a team drive and the workaround for establishing tempaltes in googledoc (copy + paste unique doc ID into “Template Document” field...could this be an issue?

I am getting a similar error. Not sure if this is related. My zap is works great when I test, but then I get this error when trying to publish my zap.

Cannot publish Zap
Specified authentication isn't for ZapierMailAPI

 

Same isssue here. 

Cannot publish Zap
Specified authentication isn't for StripeCLIAPI@2.1.0

 

Userlevel 7
Badge +8

Hey folks, sorry for the trouble here! Our team is looking into this but in the meantime, you should be able to make a copy of your Zap and then publish that copy. Are y’all able to give that a try and let us know if that resolves things for you?

 

Userlevel 1

@jesse We’re also seeing this error - We noticed that the Google Forms trigger was labeled Legacy so we were updating it to the new Google Forms trigger. We have a draft saved that has the trigger updated (and all the subsequent steps that rely on the trigger data), but cannot publish that draft due to the error this thread is talking about.

Copy does not work for us - When we copy the zap we only get the zap as it was and not our updated draft. Switching the trigger in the copy *does* seem to allow it to publish, but unfortunately it means we’d have to re-do all the other changes that the draft had which we’re hoping to avoid. Is there a way to copy the draft as well? Otherwise we’re hoping that this could be resolved without needing to copy and re-do all the work.

Thank you for your response!  

Userlevel 1

Copy and publish worked for us!

Userlevel 7
Badge +8

Hey @Menlo Developer - thanks so much for all of the great detail here around what you’ve done to troubleshoot this! Unfortunately, it sounds like drafts are affected in this particular issue, meaning that you won’t be able to publish the draft you were editing for the current Zap, nor have it copy over to the new Zap.

I’m genuinely so sorry. I know this is a big inconvenience, especially after making several changes already and now being asked to re-do them. 😔 As I have more updates, I will share them here, but as of right now, this appears to be the only way to get past this error.

Userlevel 1

@jesse No worries, was hoping there was another way but it’s not the end of the world. Appreciate your quick responses very much!

Userlevel 7
Badge +8

@UPchieve Oh I am so glad! Thank you for letting us know! 🙌

@jesse We’re also seeing this error - We noticed that the Google Forms trigger was labeled Legacy so we were updating it to the new Google Forms trigger. We have a draft saved that has the trigger updated (and all the subsequent steps that rely on the trigger data), but cannot publish that draft due to the error this thread is talking about.

Copy does not work for us - When we copy the zap we only get the zap as it was and not our updated draft. Switching the trigger in the copy *does* seem to allow it to publish, but unfortunately it means we’d have to re-do all the other changes that the draft had which we’re hoping to avoid. Is there a way to copy the draft as well? Otherwise we’re hoping that this could be resolved without needing to copy and re-do all the work.

Thank you for your response!  

Same here, copy doesn’t work at all for us. I lose all the steps.  Saving it doesn’t help either.  Now I am afraid to close the zap and lose an hour’s work. 

Userlevel 7
Badge +8

Hey folks! Just coming here to close the loop. We were able to deploy a fix for this so you should be able to publish those drafts now without having to copy and reconfigure. If you run into any other issues, just let us know and we’ll look into it!

@jesse I am just getting started with zapier for the first time and came across this issue, have not been able to publish or turn on any zaps.

 

Running tests work perfectly though. I was originally trying to make a Zap from convertKit to a discord message, which let me publish but did not have a descriptive error when it failed to turn on - “Zap disabled due to a system or configuration error”

 

I tried narrowing down the error by using other triggers besides convertKit but I encounted - “Cannot publish Zap Specified authentication isn't for DiscordCLIAPI@1.6.0” for every trigger I tried

Userlevel 7
Badge +8

Hey @kevin m - sorry to hear you’re running into some issues here! At this point, I would suggest reaching out to our support team to look into this further as this appears to be resolved for most folks. https://zapier.com/app/get-help

Keep us posted with what the issue ends up being! If there is another bug here, we certainly want to know about it and keep the Community informed 🙏🏻

Reply