Question

Buffer support not working - multiple errors

  • 15 December 2023
  • 12 replies
  • 141 views

I am trying to sync a google sheet to buffer. When a new row appears, send the video file link or carousel files etc to buffer. Zapier is reading all the data correctly, but buffer is sending errors like these:

 

Cannot read properties of undefined (reading 'ext') (this happens even when there is a public file with a url extension like .jpg)

Failed to create an update in Buffer RequestId: 1b80b4cd-51f3-403d-93e2-fc60ddbecbe5 Error: Runtime exited with error: signal: killed

 

any ideas?


12 replies

Userlevel 7
Badge +14

Hi @CommunityUser00 

Help us have context by posting screenshots with how your Zap steps are configured along with the encountered error.

yes it starts with new spreadsheet row,

then it checks for the network = true to put it toward a network (in the screenshot you see IG).

then it checks a cell to see what type of post, and it uses the buffer zap for that type of post. 

 

Userlevel 7
Badge +14

@CommunityUser00 

We would need to see detailed screenshots with how the Zap steps are configured in EDIT mode with the fields mapped/set along with the encountered error.

@Troy Tessalone 

 

this is what it is sending to buffer

Attachment

attachment

multiple_images

Channelid

channelId

657a283f1a33d19b1fb85c1f

Ig_post_type

ig_post_type

post

Image0

image0

https://freshdelmonte.com/wp-content/uploads/2022/01/banana-farm-cropped.jpeg

Image1

image1

https://freshdelmonte.com/wp-content/uploads/2022/01/banana-farm-cropped.jpeg

Image2

image2

https://freshdelmonte.com/wp-content/uploads/2022/01/banana-farm-cropped.jpeg

Image3

image3

https://freshdelmonte.com/wp-content/uploads/2022/01/banana-farm-cropped.jpeg

Method

method

schedule_draft

Organizationid

organizationId

6579fce035668fd344db64dc

Scheduled_at

scheduled_at

3/9/2024 9:30:30 AM

Updates Text

text

This would be copy

Empty fields:

Tags

Tags

empty (optional)

Image 5

Image 5

empty (optional)

Image 6

Image 6

empty (optional)

Image 7

Image 7

empty (optional)

Image 8

Image 8

empty (optional)

Image 9

Image 9

empty (optional)

Image 10

Image 10

empty (optional)

First comment

First Comment

empty (optional)

Shop grid link

Shop Grid Link

empty (optional)

 

Loading

Testing

Userlevel 7
Badge +14

@CommunityUser00 

Something to check is whether these links are publicly accessible direct download links, which are needed to be used in file fields.

https://help.zapier.com/hc/en-us/articles/8496288813453

 

@Troy Tessalone thanks, yes they are publicly accessible 

Userlevel 7
Badge +14

@CommunityUser00 

Best way to test is in a new/different private browser to make sure.

Can you provide an example of one of the links so we can check?

 

@Troy Tessalone sure, the one I am using is this, however you could grab any public image to test https://freshdelmonte.com/wp-content/uploads/2022/01/banana-farm-cropped.jpeg

Userlevel 7
Badge +14

@CommunityUser00 

Another thing to check/try would be the format of the timestamp. (perhaps remove the :ss seconds)

Check the field description for guidance.

 

@Troy Tessalone thanks! I will try that. Maybe I’ll manually put in the date instead of passing from the sheet to test

@Troy Tessalone removing the second on the timestamp did not work. it may be worth mentioning this issue is only with carousel and video buffer posts. it does work with single images

Userlevel 7
Badge +14

@CommunityUser00 

Maybe there is a bug.

You can try opening a ticket with Zapier Support: https://zapier.com/app/get-help

Reply