Best answer

Bitbucket cloud integration “Unsupported grant type” error when connecting

  • 19 October 2021
  • 11 replies

Hi there,

I am trying to intergate Zapier with Bitbucket Cloud. While performing the integration, I am receiving the following error (screenshot attached)





Best answer by SamB 14 December 2021, 11:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

11 replies

Userlevel 7
Badge +9

Hi @oscar_umanzor 

It looks like an issue with your account. I’d recommend that you get in touch with Zapier support to resolve this. You can try connecting a different Bitbucket connection to see whether the issue is with the Bitbucket app itself.

I have the same issue… this appears to be an ongoing issue that was reported 9 months ago and has not been fixed….



Userlevel 7
Badge +11

You’re quite right, @fitlijcc! This relates to a known bug that was discussed in another thread. I’ve added you to the list of affected users.

@oscar_umanzor, it looks as though you’ve already been added by our Support team. 

We’ve still not got an ETA on when it will be resolved but we will notify you both by email as soon as it is.

I have the same issue. I’ve tried this with two separate Zapier account with the same result. Is the issue on the Bitbucket side?

Userlevel 7
Badge +11

Thanks for letting us know, @shar154. I’ve added you to the list of affected users.

I don’t have any estimate on when this will be resolved or workaround to suggest here but we’ll be sure to email you as soon as there’s been an update! :) 

This appears to be an issue on Zapier’s end as other automation services, such as can connect just fine with Bitbucket. Since this issue has been a problem for over 9 months it seems doubtful that this is a high priority fix for Zapier. Regardless, if you do decide to fix it then please let me know as well.

Userlevel 7
Badge +9

Thanks for reaching out, @J0N0!

I’ve got you added to the list of impacted users. We definitely appreciate you sharing your candid feedback!

While I wish had more of a timeline to offer you, at this time we don’t have an ETA on when a fix will be available. As soon as we know more though we’ll be sure to keep you in the loop!

Hi Zapier team,

Same issue is happening to me.

This issue is reproducing for 10 months now. 


While I understand that you don’t have an ETA for the problem, I would expect at least a progress report.

Is it on your roadmap? If yes, when is it scheduled for? If no, is it not a priority for you and should we not expect it to be fixed any time soon (6 to 12 months)?


It’s no need to get a response to my questions immediately, you can take your time and gather the needed info. What I do expect though, is to get more details on the matter because it’s blocking my operations. My operations are centered around the Bitbucket integration and if there is no fix in sight, I would have to move the automation to another provider.


Thank you,


Userlevel 7
Badge +9

Hi @aapostol,

Thanks for reaching out and sharing your candid thoughts. I totally recognize how frustrating this is and want you to know it’s not falling on deaf ears. 

While I wish I had more of an update to provide you, in the interest of total transparency, we don’t have a timeline for when this will be fixed. This isn’t out of a desire to withhold information from you. More so that we truly don’t have any updates to offer at this time. I can assure you the team is actively monitoring and all reported impacted users, yourself included, will be notified via email and the thread updated as soon as there is one to provide though.

Thank you again for taking the time to share your feedback with us. We’ll be in touch once we know more.

Hi, would love to be added to the list please.


Userlevel 7
Badge +9

Hi there, @Hugo R! Thanks for reaching out. I’ve got you added to the list of affected users. We’ll be sure to email you once we have a fix in place. 🙂