Adding a second wpforms connection fails

  • 26 March 2022
  • 5 replies

We hit an error adding your new account

authentication failed: The app returned "Invalid WPForms Zapier API key".

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information

the api key and url are correct

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @adkgen 

Good question.

Please reference this help topic:


I tried both chrome & Edge browsers, installed wpforms multiple times, installed the zapier integration multiple times all with no success

Userlevel 7
Badge +14


Have you tried using a private browser?

Userlevel 7
Badge +14


One workaround is to use the Webhooks add-on instead of the Zapier add-on:

The Zap trigger would be Webhooks - Catch Hook:

yes again with no luck. what I have found out is if I try and add a connection between a wpfroms/wordpress install that is not in the root directory of the domain it fails. we are trying to create a private system for just field technicians to use to share information. Zapier does not seem to work with multiple word press sites under 1 main domain. example we were trying and it keeps failing. But goes through with no issues.


Now we are designing the site to use 1 wp install with network site installs