Best answer

"Access denied" error while using lexoffice

Hello community,

I have just set up an invoice Mail with the sole purpose for our suppliers to send their invoices there.

I am trying to set up a zap, that automatically uploads the attached files in the microsoft outlook account.
So far, so good.

When I test the zap, I receive the error message “Access denied”. I tested the connection to Outlook and lexoffice, both seem fine. I have no idea, where the error could be.

Thank you for your time and help!


Best answer by SamB 10 July 2024, 15:43

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

15 replies

Userlevel 7
Badge +6

Hi there @AsaZaps,

Welcome to the Community! 🎉

I'm sorry to hear that you're having trouble with your Zap. Before we dig deeper, could you please provide us with a detailed screenshot of how your Zap is configured, specifically the "Action" section of lexoffice? This will help us better understand the issue.

Thanks! 😊

Hey there,

thank you for your fast reply! I have attached a screenshot, please let me know if you need more information :)

Userlevel 7
Badge +6

Hi there @AsaZaps,

Thanks for the screenshot!

The fields looks like it has been mapped correctly. To test, could you please try creating a new sample data in Microsoft Outlook and ensure that there’s an attachment on that email? After that, select the recently created sample data from the trigger step by clicking “Load more.” Like so:

(view larger)

After that, please try testing the lexoffice action step again.

Please give that a try, and keep us posted! 😊

Hey Ken, I have tried that step with two different sample E-Mails, but the error still occurs. Do you have another idea? :/

When i tried it a third time, I get this error message;

“Error from halted execution: Unable to upload file: The file type is not supported.”
Userlevel 7
Badge +6

Hi @AsaZaps,

Thank you for trying that out. Can you please let me know if the attachment in your Microsoft Outlook email is a PDF file? If it is, we have an open bug report for a similar issue that you are encountering.


Hey Ken,

Yes, it is a PDF-File :) So it isn’t fixable right now?

Userlevel 7
Badge +6

Hi @AsaZaps,

Unfortunately, the error you’re running into is a known bug with the lexoffice integration. Our team is aware of the issue and we're working with lexoffice on a fix. I've added your email address as another affected user. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track and prioritize fixes
  • Allows us to notify you via email if/when this is fixed

Unfortunately, I do not have an ETA, but I’ve added you to the list of users affected by this issue so we can let you know as soon as we have any updates.

I’m really sorry for the inconvenience this bug may have caused you. If you have any other questions, please don’t hesitate to ask them in the Community. We’re always happy to help!

Hey Ken,

Alright, no problem, thank you for your help anyways!

Please let me know, when this bug is fixed :)


Userlevel 7
Badge +6

Hi @AsaZaps,

You're absolutely welcome!

No worries at all, we'll make sure to keep you in the loop through email or right here in this thread if there are any updates regarding the bug.

Thanks! 😊

Hey there, I’m having the same issue. Tried setting up a Zap for Bookkeeping purpose. 

I’d like to be able to forward a Mail with an invoice to a Mail Adress and have the document uploaded to Lexoffice  automatically. That would be awesome. Hope there’s news on that.

I’m getting this error message even though it’s just a PDF file.

Error from halted execution: Unable to upload file: The file type is not supported.

Userlevel 7
Badge +11

Thanks for letting us know @volly92!

Sorry to hear you’re being affected by this issue as well. I’ve added you to the list of users being impacted by that bug. We’ll send you an email notification as soon as it’s fixed.

Hi there, @SamB and @ken.a,


are there any updates here?

I have the same issue. This connection is the reason why I upgraded my zapier plan :(


Appreciate some feedback.



Userlevel 7
Badge +11

I’m so sorry we missed your message here, @Karolyne.

I’ve checked on the bug report and it’s still unresolved at present. We can’t give any sort of estimate as to when it will be resolved by unfortunately, but I have added you to the list of folks being affected by it which does help to increase it’s priority. We’ll be in touch via email as soon as it’s resolved.

Really wish I could I could do more. If we come across any updates or workarounds in the meantime, we’ll be sure to share details of them here.

Userlevel 7
Badge +11

Hey folks,

Just following up here to share that the lexoffice team have released a new version of their app on Zapier which should now have resolved this issue! 😁🎉

To take advantage of the fix they implemented you’ll want to ensure your Zaps are running the latest version of the lexoffice app. See our Update to the latest app version in Zaps guide for details.

That said, if you’re still experiencing issues please do reach out in the Community or get in touch with Support. In the meantime, happy Zapping! ⚡