Best answer

500 error with WordPress authentication conflict with PODS plugin

  • 26 May 2023
  • 4 replies
  • 122 views

We're back with a follow-up question about the issue that we experienced with Zaps not functioning upon upgrading the Pods to versions 2.9.11, 2.9.11.1, 2.9.12, 2.9.12.1, 2.9.12.2, and 2.9.13. We’ve checked the server error log and found an PHP Fatal error:  Uncaught ArgumentCountError: Too few arguments to function FirebaseJWTJWT::encode(): 2 passed in /wp-content/plugins/zapier/zapier.php on line 126 and at least 3 expected in /wp-content/plugins/pods/tribe-common/vendor/firebase/php-jwt/src/JWT.php:183

Can you help or guide us on how to resolve this error?

icon

Best answer by SamB 2 May 2024, 14:43

View original

4 replies

Userlevel 7
Badge +11

Hey there @writerscentre! 🙂

I’ve been looking into this and found that we’ve got a bug report opened for this error. So I’ve added you to the list of affected users. I don’t have any ETA on when this issue will be fixed exactly but we’ll be sure to notify you by email the minute it’s been resolved.

From what we can tell it appears to be caused by a compatibility issue around the Firebase/JWT library version used. Perhaps if you switch to using a slightly older version of the Zapier plugin that uses a different version of the Firebase/JWT library perhaps that will get rid of the error in the meantime? 

I’ve not tested this theory out myself but if you do manage to get it working, or find an alternative solution in the interim please do let us know! 

Hello @SamB,

Thank you for providing the information about the bug report and the possible cause of the error. It's good to know that we have been added to the list of affected users and that we'll be notified by email once the issue is resolved.

Regarding the suggestion to switch to an older version of the Zapier plugin that uses a different version of the Firebase/JWT library, we appreciate the recommendation. We have tried using Zapier version 1.0.2 and Pods version 2.9.10.2 on our staging site, and we can confirm that the Zaps work fine with these versions. We are hopeful that the compatibility issue will be fixed soon.

We'll continue to monitor the situation and look forward to the resolution of this issue. If there are any further updates or alternative solutions, we'll be sure to let you know. Thank you for your support and assistance.

Best regards,
@writerscentre 

Userlevel 7
Badge +6

Hi @writerscentre,

I’m glad SamB was able to add you to the open bug report. Also, we’re glad to hear that the workaround worked.

If you have any other questions, please don’t hesitate to ask in the Community. We’re always happy to help! 😊

Userlevel 7
Badge +11

Hey folks,

Following up here to confirm that the bug related to compatibility issues with the Firebase/JWT library has been fixed! 🎉

Please note: in order for the bug fix to work you’ll need to upgrade the Zapier for WordPress plugin is to v1.3.0 or later.


If after upgrading you’re still experiencing issues please reach out in the Community or get in touch with Support directly

In the meantime, happy Zapping! 😁⚡

Reply