Best answer

404 Wordpress Authentication Issue

  • 22 February 2023
  • 7 replies
  • 190 views

Hello! I’m trying to connect my WordPress to Zapier. But it’s giving me a 404 authentication error. I’m running the most current versions of WordPress and the Zapier plugin. And the plugin is installed and active. I’ve tried everything I could find that was recommended to other folks for this problem (making permalinks post name, reinstalling the plugin, and making sure xml-rpc is enabled. Please help!

icon

Best answer by Danvers 22 February 2023, 15:42

View original

7 replies

Userlevel 7
Badge +12

Hi @byDSGN!

Wordpress connections are tricky because so many factors play a role in them. 

 

If you haven’t already done so, I recommend going through this help doc: Common problems with WordPress

If you’ve already tried that and/or it doesn’t solve the issue, I recommend going to the Support Team using the Get Help form. They’re able to look at your Zaps logs and can provide more insight into what’s happening. When you message them, be sure to include details of everything you’ve tried so far, so they don’t ask you to try them again. 

 

Thanks!

I am in the same situation as above author, I’ve been through the entire forum for info and trouble shooting. Starting to lose my mind here.

Userlevel 4
Badge +6

Hi @Theodore W 

Kindly open this help doc about the issue: Common problems with WordPress.

Hopefully this helps!

Hi @Theodore W 

Kindly open this help doc about the issue: Common problems with WordPress.

Hopefully this helps!

Hi @Brem , I am also having the same issue. I have looked at all the support pages and documentation, and still can’t seem to fix the issue. 

Userlevel 7
Badge +6

Hi @10slindsay,

I’m jumping in to see if I can help!

Before we dig in, could you please confirm that the Zapier WordPress plugin is installed on your website and that you have admin permissions on your WordPress account? This is required to connect WordPress to your Zapier account.

I also checked our notes and found a similar issue with another user. They discovered the hosting provider was blocking traffic from Amazon AWS, which Zapier uses. Some changes in the firewall on their end did the trick.
 
Also, here are a few other things to remember: 

  1. Make sure to reconnect the account and make sure to include the WWW  part of the URL
  2. If that doesn't work, the next step would be to temporarily deactivate any security plugins that could interfere with us trying to connect.
  3. Also, is it possible to check to ensure that the WordPress Plugin is activated in the Plugin Dashboard? https://help.zapier.com/hc/en-us/articles/8496101767309

Does that point you in the right direction? Please keep us posted! 😊

Userlevel 1

Hi, 

Has there been any follow up on this topic? I have been trying to connect a Wordpress account multiple times, looked through all the community help posts and did every suggestion, and nothing seems to be working. This is the error I get:
 

 

Could you please let me know what are the other possible fixes? I tried the following (probably even more)

  • Disabling all the plugins
  • Activating the Zapier plugin & have admin access
  • Added another account Zapier as a user
  • Tried downgrading WP version to the one that was last tested with Zapier
  • Etc (can’t remember all but basically all that have been mentioning on this blog).

It’s really important for me to get this integration for my client who uses WP a lot. Thus, it would be great to get some help on this, since so far nothing seemed to solve the issue for me :)

 

Thanks in advance!

Userlevel 7
Badge +6

Hi @OptimAIze Labs,

I’m so sorry to hear about the trouble connecting WordPress with Zapier.

Before we dig deeper into this, could you please confirm if you have the WordFence plugin installed? If so, could you please try disabling the plugin? 

If it still doesn't work, could you please check if any settings in WordFence might be conflicting with the Zapier plugin.

Please keep me posted!

Reply