Question

Zaps for specific products in Kajabi


I have two similar products in Kajabi. Each product is a different price point. 

Whenever I set up my Zaps, I’m unable to connect it specific to each product. My payment processor is Stripe. It seems as though when a product is purchased, it should grant access to the specific product, however, it isn’t. The result is that my Zaps are executing based on a general action for all products. Can someone help share advice on how to make my Zap more specific to each individual product in Kajabi. 

Thank you for your help in advance.

 


10 replies

Userlevel 7
Badge +14

Hi @ZapRookie 

Good question.

Try using separate Zaps for each Product with a Filter as Step 2: https://zapier.com/apps/filter/help

Userlevel 7
Badge +9

Hiya @ZapRookie! Thanks for reaching out in community! 

I wanted to share some extra resources for the Filter by Zapier app.

Hopefully some of that helps get your wheels turning. 🤗

So it might look like:

  1. “New Payment” - Stripe Trigger
  2. Filter by Product
  3. “Grant Access to an Offer” - Kajabi Action

Keep us posted how this is working out for you! 

Hey Zap Community!

 

Ok...I’m still struggling with this. 

 

Here is the context:

  • I have 2 products within Kajabi. 
  • Both are different price points (ex. Product 1 = $36 (subscription), Product 2 = $50 (one-time use product)
  • I have set up a unique Zap that grants offers to each product specifically.
    • Product 1:
      • Trigger: New Subscription
      • Action: Grant Offer to Product 1
      • Result: Both products are sent to the New Customer
    • Product 2: Seems to be working as intended
      • Trigger: New Purchase
      • Action: Grant Offer to Product 2
      • Result: New Customer receives Product 2 only
         
  • UNFORTUNATELY, whenever some purchases the SUBSCRIPTION (aka Product 1), they are receiving both Products automatically. 

HELP, HELP, HELP! Thank you all!

 

ZapRookie

Userlevel 7
Badge +14

@ZapRookie

Can you post detailed screenshots with how your Zap steps are configured in order for us to have full context?

 

Try using separate Zaps for each Product with a Filter as Step 2: https://zapier.com/apps/filter/help

Userlevel 4
Badge +6

Hey there @ZapRookie, as Troy mentioned please add some screenshots of your Zaps so we can take a closer look. From what you’ve said, I’m thinking it may be an issue of mapping of fields.

Are these two different Zaps or one four step Zap? Knowing that makes a big difference!

Let me know if you still need help with this! 

@Troy Tessalone, @chanelle,

 

Please note that there are 2 Zaps. One is working correctly. The one in the pdf attachments is issuing both products for some reason. It grants 2 products at times.

 

Userlevel 7
Badge +14

@ZapRookie 

Check your Zap Runs history details to see the DATA IN/OUT for each Zap step to help you troubleshoot to try to isolate the issue: https://zapier.com/app/history/

Userlevel 7
Badge +14

@ZapRookie

Here’s why…

In the Filter step you have the left side argument and right side argument comparing to itself which will always evaluate to TRUE.

You need to add static values to the right side for each condition.

 

@Troy Tessalone 

 

Would you be able to provide visual examples to help? 
 

Thank you!!!

Userlevel 7
Badge +14

@ZapRookie 

On the right side for condition 1, remove the mapped variable, and type in the desired Plan Amount value. (e.g. 36)

On the right side for condition 2, remove the mapped variable, and type in the desired Object value. (e.g. subscription)

 

Reply