Best answer

Zapier had trouble retrieving custom fields from Autotask

  • 23 September 2020
  • 4 replies
  • 209 views

Userlevel 1

“Zapier had trouble retrieving custom fields from Autotask” when do this equals create Ticket in Autotask

icon

Best answer by Liz_Roberts 25 September 2020, 18:59

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +8

Hi @RCI ,

Thanks for reaching out! You have stumbled upon a known Autotask bug. As a workaround, the Autotask team has suggested that folks create a new API user, with no association to any Vendor.

I have added you as an impacted user which does a few things:

  • Re-raises this issue with the app’s team
  • Adds weight to the issue in queue
  • Reminds us to update you once this is resolved

I don't have an ETA on when there might be a resolution, but you'll definitely be notified as soon as there is an update!

Same Issue, and I already have an API user

Userlevel 7
Badge +8

@tflach you have been added to this report and will receive updates via email!

Userlevel 7
Badge +12

Hi everyone! I’m happy to report that this bug has now been resolved

 

Here’s what the team have said:

We've worked with their team to identify the problem where where the fields could not be retrieved in the Create Ticket action. This issue was being caused by an Invalid Username or Password error. We believe this issue is resolved!

If you are still experiencing this issue, please create a new API User in Autotask that will be used ONLY with the Zapier integration. Ensure that * You record your username and password in a safe place before saving, for reference when autheticating with Zapier after * you are selecting Security Level API User (system) * Under API Tracking Identifier you have selected Integration Vendor * In the Integration Vendor Drop Down, you have selected Autotask - Zapier Connector

 

I hope you can give this a test soon. If you do happen to encounter this issue again (or any other issues!), please contact the Support Team using the Get Help form so we can work to resolve it.