Zap not triggering - FB Lead Ad

  • 18 July 2021
  • 5 replies

Hi I really need some help. My zap is not triggering. Leads are coming in from Facebook, but they are not being sent to my Google Sheet or Activecampaign.


I’ve tried everything at this point. I tried resetting Zapier permissions, full Zapier reset, reset my Leads Access on Facebook. I even tried using the admin’s Facebook page for the Zap and that still didn’t work.


Please someone help.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +7

Hi @Bart ,

Can you please share some more details? How does your zap flow look like? How did you connect which apps? etc.
Screenshots help a lot as well.

~Bjorn from Wemakefuture

@Wemakefuture attached zap flow below. I use the client’s Activecampaign account. Otherwise, all other apps are linked through my personal account. I am an admin of the client’s Facebook page and advertiser on the account as well. 





This post has been edited by a moderator to remove sensitive information. Please remember to obfuscate any personally identifiable information prior to posting as this is a public forum. 


@Wemakefuture any ideas???

Userlevel 7
Badge +7

Did you check if Zapier installed the CRM App? 


Please follow and check if every step here is done: