Zap not pulling information from my google form to my pipedrive Why?

I noticed that while creating my ZAP,  on the trigger page, zap is connected to my google form and i see all the columns of my form.

In the action page, I put all corresponding google form fields into  my pipedrive fields and the Zapier says “missing title”  Not only that, i tried putting a normal text, which is my name, the zap now worked. But when i fill the google form, Zapier never pulls any infomation from my google form. What to do next?

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +10

I think this might be best for someone from the team to check into. 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon..

Userlevel 7
Badge +8

Hi @spinos - I’ve filed a ticket to our support team for further assistance. Please don’t forget to provide us with further details within that ticket so that we can help you resolve this. Thank you so much!