Zap instantly copies an empty row

  • 13 October 2020
  • 6 replies

Userlevel 1

Gretings, community members!
I’m new here.

I created a Zap that supposes to add a new row in the Smartsheet when a task created in the Asana.
And it works fine if I make the task through the “+” button in Asana (that workflow implies to fill all the data and then select “submit” to post it as a new task). 

But when I create a task through the Project menu - Asana immediately ads empty row (the trigger event) it contains only system fields filled and the user field should be filled before saving and sending. But my Zap copies this empty task into the Smartsheet.
I thought that the Delay action can help me, but no, the trigger event copies what it sees, doesn't wait for the user fields being filled.

Could you suggest how i can solve this problem?

Thank you!

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 4
Badge +4

Hi @Vladimir Opanasiuk ,

Can you clarify what you mean be the + symbol and the project menu methods of creating a task?

Maybe make a screen recording so I can see the exact steps you use.  It will help troubleshoot why one way works and the other is  triggering too soon.


Also as a quick solution try combing the a delay with doing a “Find Task by ID” step to get the most recent task information.

Userlevel 1

Hello @BowTieBots 

There are two ways to create a new task:

a) is the "+" Plus icon (1 on the screenshot), using this option I have to fill in all user fields for the new task and then pselect “create task” (2 on the screenshot) it. And my Zap copies everything correctly to the Smartsheet. 

b) But if I select the Add task button in the Project board (3 on the screenshot) it will instantly create a new task row where I have to fill the user fields before saving & sending it to the Smartsheet. The problem is that my Zap triggers on it as a result it copies the empty row. 

I look like the "new task added" trigger reacts to each new task, no matter if it filled with user data or not.


Userlevel 4
Badge +4

@Vladimir Opanasiuk I solved this in my zaps by using the delay function like you have and then looking up the task by the id to get the information I may have entered after it triggered.


Basic set up is:

  1. Trigger on new task in Asana
  2. Delay for 5 minutes
  3. “Find task by ID” using the task ID from 1
    1. This will pull in whatever the current task values are
  4. Continue as normal


It’s a nuance of what the API considers a new task.  Option three creates a task instantly and then you are technically making updates to it. Method 1 the task doesn’t exist until you click “Creat Task”. Since Asana is an instant trigger it requires a few extra tasks to make sure all the information is present.

Userlevel 1

@BowTieBots tried to do it this way. On step 4 I noticed that only the default fields from step 3 are available for mapping. Asana's columns created by the user available for mapping only from step 1. 
So, now it creates not empty rows but filled with: task name, date, due-date  (they are default in Asana). The fields created by me (amount, currency, vendor, etc.) are left empty.
I thought that probably it’s Smartsheet’s limitation and made the same Zap for Google Sheets, but nope, it does the same:\\\


Userlevel 4
Badge +4

Hi @Vladimir Opanasiuk ,

The values are there they are just a little harder to get to because of the way Airtable returns them to Zapier.  Look for a value called “Custom Fields”.


You will need to pass that value to a Formatter Split Text step to pull out the line items.  

Do any of your custom fields include commas “,”?  If so you will need to be specific about what you use as a seperator.

Also is there a possibility that a field value may be blank?

Userlevel 7
Badge +10

@Vladimir Opanasiuk 
Just checking in to see if you still need help with this?