WooCommerce authentication error: 405 Method not Allowed

  • 20 July 2020
  • 4 replies
  • 516 views

Userlevel 1

I also need help with this as I am having the same issues.

 

This is the error I am getting 

 

We hit an error adding your new account

authentication failed: request to https://paces.co.uk/wc-zapier-auth/v1/authenticate failed, reason: unable to verify the first certificate

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information

I have tried disabling plugins, this did not change anything 

 

http://paces.co.uk/wc-zapier-auth/v1/authenticate

 

{"code":"wc_zapier_method_not_allowed","message":"405 Method not Allowed","data":{"status":405}}

 

Which seems correct but I still can not connect 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +10

@jimmcgettrick 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +12

Hi @jimmcgettrick - I moved your reply to a new post as it’s related to a different error message, I hope that’s ok!

 

When we see the error message {"code":"wc_zapier_method_not_allowed","message":"405 Method not Allowed","data":{"status":405}} it’s most commonly related to a plug in issue. I know that you said you disabled plugins, but could I ask you to double check that they are all disabled? Specifically ones that is forcing canonical URL settings (eg Comet Cache Pro) are known to cause this error. 

 

One other thing that I spotted in the error message is that says ‘unable to verify the first certificate’ - if you’re using a redirect url, do you know what the SSL certificate settings can sometimes that can cause issues with authentication.

 

For authentication issues generally, the WooCommerce help guide on troubleshooting guide is really helpful: Troubleshooting authentication issues I couldn’t see the 405 issue specifically listed in that guide, but there might be another clue. 

 

If that doesn’t help, then the best bet here will be to contact the Support team using the Get Help form: https://zapier.com/app/get-help If you do head down that route, be sure to mention what you’ve tried so far as that will help them to get up to speed quickly.

I’m having this same problem. Did you ever find a solution?

Userlevel 7
Badge +10

@agould 

Have you followed the steps @Danvers outlined above? If not, let’s get you in touch with Zapier support for more help.