Why is a blank white box appearing before the content of my campaign HTML?

Userlevel 1

Hi everyone, 


Thank you all for helping me in my previous post about mantaining style when sending mailchimp campaigns and automating a post creation in WordPress.

As for now, I am able to mantain my mailchimp campaign style in my wordpress site. The problem now is:

A big white blank box/space appears before the content of the campaign, i have used the inspect tool and the box has the following content

<p> == $0
<!-- NAME: 1 COLUMN - BANDED -->
<meta Content-Type content="text/html; charset=UTF-8"> == $0
<meta name="viewport" content="width=device-width, initial-scale=1.0>

Why is this content inside my html? If i copy/paste my HTML code directly from the mailchimp campaign this problem wont happen. It only appears when automating the process with Zapier.


Has anyone else faced an issue like this? What did you cam up with to solve it?


Thanks in advance

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +9

Hey @BigData HOSBEC oh, that’s so strange! I am assuming you’re using the “New Campaign” trigger for MailChimp, is that correct? If so, and you look at a recent run from your Zap History, so you see this HTML coming across within the Trigger data?

If not, do you see it in the Wordpress Post output within the run? That should give us some insight as to which step of the process might be adding this and what our options are for moving forward!

Userlevel 1

Hi @jesse , thanks for your quick response!

Yes, I am using the “New Campaign” trigger in Mailchimp and the “Create Post” action in WordPress.


The data (html) out from MailChimp doesn’t look exactly like the code ive added before, but it’s as follows:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">
<html xmlns="">
<!-- NAME: 1 COLUMN - BANDED -->
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">

Exactly the same code is shown in “archive_html” from MailChimp and in the “ content” recieved in Wordpress.


While the raw content stays exactly with this code, the “rendered” content from the (Data out) section in my Wordpress zap introduces the problem and changes the code to:

<p><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" ""><br />
<html xmlns=""><br />
<head><br />
<!-- NAME: 1 COLUMN - BANDED --><br />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><br />
<meta name="viewport" content="width=device-width, initial-scale=1.0"><br />


Is there anyway to set how the content is being rendered to avoid extra spaces or paragraphs?



Userlevel 7
Badge +9

@BigData HOSBEC Ahh, I see - thanks so much for those screenshots! It’s clear on where the issue is. However, I’m not sure why that is happening. 🤔 For this one, I am going to suggest contacting our support team so they can look into some logs and get to the bottom of this. You can get in touch with them using the form here:

We’ll be following along but please do keep us posted if you manage to get this resolved in the meantime!