When do Zaps trigger automatically?

  • 10 June 2021
  • 5 replies

I just spent an hour or so trying to get one of my Zaps to trigger, and nothing seemed to work. Then suddenly when the clock struck noon (PST), all of the Zaps I had attempted to trigger over the preceding hour launched at once.

Does anybody know where I can adjust this setting so that my Zaps will run at any time?



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Team Fuzey! 

Trigger Types

There are 2 types of triggers:

  1. Polling trigger: the majority of triggers are polling triggers.
    With a polling trigger, Zapier will check for new data from your trigger every 1 to 15 minutes in order to start your Zap, depending on your pricing plan.
  2. Instant trigger: with an instant trigger, your trigger app will send Zapier an instant notification whenever there's new data.
    Zaps with instant triggers are labeled Instant on your dashboard and in the Zap editor.


@Troy Tessalone - thanks for the response!

I had/have the Zap in question set to ‘instant’ but for whatever reason no matter how many times I attempted to trigger it over the course of an hour or two this morning, nothing happened.

I tried copying the Zap which didn’t work, and tried recreating it entirely from scratch which also didn’t work (all set to instant)… but then suddenly all 3 versions started working again at once, and all of the backlogged ‘tests’ I had attempted, ran.

And now it’s working as intended, triggering instantly without fail like it was yesterday.

As far as I can tell, the issue isn’t the trigger type, instead it almost seems like my Zaps are only set to be triggerable between certain hours - does that make sense at all? 

I’m going to attempt to trigger the same Zap tomorrow morning around the time it wasn’t working today to see if the problem persists, but if you have any other ideas I’d love to hear them!


Userlevel 7
Badge +14

@Team Fuzey! 

Sounds like there might have been an intermittent issue with the trigger app.

You can check the Zapier Status here for incidents:

@Troy Tessalone 

Gotcha, that’s good to know. I’ll give it another shot tomorrow morning around the same time to make sure everything is running smoothly.

Thank you again for your help! 


Userlevel 3
Badge +5

Hi @Team Fuzey!, I just wanted to check in with you to see if the Zaps are working correctly now, or whether you could still use some help here. Please let us know!