Question

What reactions emojis work with slack

  • 10 August 2020
  • 9 replies
  • 772 views

Userlevel 1

I’m trying to set up a Zap for when someone leaves a reaction in Slack, then it adds a row to a Google sheet. 

 

I don’t see any of the standard emoji listed. Is there a list of emjoi that will work with this Zap? 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +10

@lindsay p Slack allows you to customize and add as many custom Emoji as you desire so there’s a ton of possibilities, however here are the standard emojis that Slack provides. All emojis (that are configured within a slack team) can be used as reactions emojis in slack.

 

Are you trying to filter on specific emojis or are you wanting a list within google sheets so you can keep a tally?

Userlevel 7
Badge +11

@lindsay p As @PaulKortman mentioned, the emojis that show up in the Zap should be the ones that exist within your Slack team. You can see all of them by going here (insert your own Slack team name):

https://insertyourteamnamehere.slack.com/customize/emoji

Userlevel 1

I am trying to use the reaction option as well. I don’t really care which emoji it is, so I just picked :bowtie: because that was one of the 44 Zapier showed me (even after I clicked ‘load more’). That doesn’t include all the ones I can see when I try to add a reaction to a message in Slack, 

My problem is that when I try to test it, it isn’t working. It let me pick a channel (I tried two different ones) and it let me select the bowtie emoji, but when I try to test, it says it can’t find any messages that I’ve reacted to in the channel. I tried doing it without setting the user (in hopes that a single zap will work for multiple users) and setting it specifically to my user. It didn’t test successfully in either case.

I filed a support ticket, but figured I’d dig around in here while I wait.

@nicksimard @PaulKortman, I would definitely appreciate any help you can provide. I’ll keep looking for other community posts that relate.

Userlevel 1

@Danvers I saw you talk about reacting to reactions on a post about mentions; I don’t think mentions will work for me, but as you can see above, neither are reactions. If you have any suggestions, I’d be grateful!

Userlevel 7
Badge +8

Hi @todd_at_sh ,

Hopping in as I see Wes from Support has sent over some follow up questions to help troubleshoot here! It seems the culprit may possibly be due to a shared or private channel, but I will let you continue working with them to confirm!

Userlevel 1

@Liz_Roberts I saw your comment about not being able to test reaction connections on the post below.

Is that still an outstanding issue 4 months later? I guess it is, since I WAS just able to skip the test and then set it up to email me the raw message text.  That may be enough to allow me to proceed with the task at hand, but is the Zap going to be reliable with this issue lurking? Is the issue limited to the testing phase, or could it crop up later in the actual operation of the Zap?

Thanks!

 

Userlevel 3
Badge +1

 

Having this issue as well, but can’t add my voice to the original topic as affected user. It’s a real PITA since it’s very difficult to get the relevant zap data for all the subsequent steps.

We see this issue with a public channel where the Reactji is added by normal users (not bots)

Userlevel 7
Badge +11

Hi @todd_at_sh and @jphorn!

When you’re testing that step in your Zap, are there messages that have been reacted to recently with the emoji you select? I don’t know the exact amount of time is too long, but in the past when I’ve run into this, I react to a message using my desired emoji and when I re-test, it finds that one.

Also, make sure the message itself is recent. Again, I don’t know the exact number of minutes that is too far back for us to see, but if you find a recent message (or create one) and react to that, I’m hoping that works for you!

Any chance you could give that a try?

Userlevel 1

@nicksimard it seems as if the problem exists only in the Zap build screen. I have a Zap that works fine to send me an email when someone picks the bowtie reaction, but even if I create a message and then immediately set the bowtie reaction and then immediately come back and have it test, it doesn’t see it.