Question

We’re having trouble loading 'Trigger Rule' data

  • 8 October 2020
  • 6 replies
  • 554 views

Trying to create a zap for exporting new orders in WooCommerce to a Google Spreadsheet, but I’m getting this error message:
“Trigger Rule response parse failed”.


How do i fix this?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +11

Hi @TBerglund!

I think this help doc from WooCommerce will help clear up that error message you’re seeing.

You have to create something on the WooCommerce side in order to then be able to select that in your Zap. Can you take a look at that documentation to see if it helps you out?

Thanks for your input, but I already have a lot of orders in WooCommerce for Zapier to find, so that shouldn’t be a problem.
The problem is when i click on Customize Order - Trigger Rule - Choose Value, it doesn’t enumerate the list, instead it gives the error message above.
Isn’t it suppose to enumerate the list with options, or am I getting this all wrong?

Running into the same issue. More specifically I'm getting this error too List Resource response parse failed. Everything looks to be in order but I must be missing something. 

 

Please advise.

Userlevel 7
Badge +8

Hello @TBerglund and @wsaa_dev - Under this particular page: https://docs.woocommerce.com/document/woocommerce-zapier/#authentication-errors, it discusses the errors you both have mentioned. I’ve added the screenshot below to show which section it’s located under: 

 

Hi,

 

Unfortunately I have the same problem. Looked at the documents you added in the last couple of post, but can’t find the solution. 

Could you please help me out?

 

Hi there,

WooCommerce Zapier Integration developer here.

Message about throttle indicates a  proxy, CDN or load balancer configured in front of the WordPress installation. The WooCommerce Zapier Integration need unfiltered access in its plugins endpoint. 

We have a couple of suggestion in  our documentation: https://om4.io/woocommerce-zapier-documentation/troubleshooting/#authentication-errors

Please note that this type of configuration issue usually happens during authentication but looks like the initial authentication was OK, but the subsequent requests get throttled.

For reference here is the list the plugin endpoints: https://om4.io/woocommerce-zapier-documentation/developer-documentation/#api-endpoints

I hope it helps,

Csaba  
OM4 Software