Best answer

"We couldn't find a new label added to card"

Userlevel 1

I’m trying to create a Zap that triggers when a new label is added to a card in Trello, but Zapier is consistently failing to find any testing data to set the zap up.

Not only have I created multiple test cards with the label added to use for testing - I’ve tried it across multiple boards where there are a whole load of relevant labels that have been added recently. But for some reason, on any board or label I try, it’s saying it can’t find any data to use.

This isn’t the first time I’ve had issues with Trello card label triggers causing inconsistencies on Zapier - but this is the first time it’s completely failed to bring in any test data at all - very frustrating! Any ideas please?


Best answer by Rachael S 5 May 2022, 17:08

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 5
Badge +7

Hi @Hyde - ugh, that is frustrating. Let me try to help you get to the bottom of what is happening. 

A first thought: there are two somewhat similar actions you can choose from in Trello: 


When I ran through building this zap, I was able to grab some test data under “New Label Added to Card”.


Also, what may help is once you get to the test step, to try adding the label at that point, then coming back and finishing the test. If you want to come in and let me know if you are able to pull that data in successfully, and if not we can keep doing our best to help you get what you need! 

Userlevel 1

Hi @Rachael S 

Thanks for coming back to me - I’ve just tested again and it’s now working for some reason.. I definitely chose the ‘new label added to card’ trigger last time as opposed to ‘new label’, but perhaps there were some delays or temporary issues - anyone seems to be working, thanks for response!

Userlevel 7
Badge +11

@Hyde Great to hear that things are working for you now. Thanks for letting us know :)