Best answer

Using Zapier with (v2.0 of API Beta) to update board from a Google Sheet record

Hi All :)

I am updatting a Board from a new Google Sheets record.

I currently have a zap set up with's v1.0 API that takes 8 tasks of the allowed 750 monthly tasks. It works fine.

I wanted to do this with less tasks so in the second (I was granted access to the new) API v2 there seems to be a task associated with updating multiple cells.

I am now able to post 5 of the 7 column values to the correct cell in the board (Board_ID: 518892687) 

However, when using the v2 API integration on Zapier I get errors for two of the columns I want to post to:


  1. The first one is a date column:

Post image

I get this error:


Post image

In the previous version of the Zapier API ( I also did a column post with this date that worked fine after I formatted it using the Formatter by Zapier app task.

Currently, the date that is sent to the pulse is formatted as this (YYYY-MM-DD): Column_ID = date_of_job where it needs to be updated.


Post image

Is this formatting the issue? Or something else?

The second issue I have is trying to update a number column (Column_ID: time_spent_in_hours)

And when I attempt to push that value through, I get this error:


Post image

As you can see from the examples above those 2 records are giving these errors respectively, so I have isolated these two problems.

If I run the zap like this:📷

Post image

Without the date_of_job and time_spent_in_hours included in the data send, It updates fine on the Monday board.

Can someone please point me towards a forum where I can raise this issue? Thanks so much!


Best answer by Liz_Roberts 15 June 2020, 17:57

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +12

Hi @Johnhenryo This looks like it would be best answered by the Support Team. They will be able to take a closer look at the Zaps in question, as well as the logs that we have for them. 


I've escalated this to the Support team and someone will be touch via email to help you with it as soon as possible.

Userlevel 7
Badge +8

Hi @Johnhenryo ,

Circling back here as I see you were able to work with Caleb in Support on this! 

To help other users should they encounter a similar issue, I am providing their paraphrased response below. I hope that got you pointed in the right direction- if you have any other questions please don’t hesitate to let us know!

“ (v2.0 of API Beta) is still an invite-only app on Zapier, this question can be best handled by their team. The integration wasn’t built by our developers and hasn’t yet gone through our testing and feedback process, but once it does we should have more insight to offer!”

Userlevel 2

@Liz_Roberts  Your date is in the correct format as the time is optional.  As a reference, here is the correct formatting to use for the date:  For the number, it looks like the data sent back to is not in the correct format...nothing you can do but report to Zapier help-desk.

I have built custom Zap using the API due to some of these issues.  Can you continue to use the V1 of the APIs until this is fixed?