Question

Updating Rows on google sheets to Knack

  • 3 March 2021
  • 4 replies
  • 29 views

Hello, I am new to Zapier.

I have managed to set up the trigger successfully, and also the action to create a new record i Knack. As you can see here:

 

Therefore, after I do this i go to my google spreadsheet and i update the row from the bottom (just like it requires). I also check if Zapier has recognised this and according to this it does recognise the new rows: 

 

However, when I check Knack, nothing ever seems to update? I have tried refreshing it and a new record is never added. Why is this so? Am i missing a step to make this happen?

I have always been under the assumption that when I make this google sheets integration, anything that I ever edit on my google sheets will automatically be updated in Knack. Am i wrong? please correct me and care to explain if so.

 

Thanks for your help.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Hi @Sean M 

Please provide screenshots of how your Zap steps are configured, with the mapping of data points from step 1 to step 2.

Check your Zap Runs history for the DATA IN/OUT of each step: https://zapier.com/app/history/

Hi @Sean M 

Please provide screenshots of how your Zap steps are configured, with the mapping of data points from step 1 to step 2.

Check your Zap Runs history for the DATA IN/OUT of each step: https://zapier.com/app/history/

Here are the proposed steps: 

 

However, I have tried to tweek this. Where it says Data in i noticed only the object key was changing. Therefore, I tried to edit it further:

 

Here now i realised I may need to physcially assign each field. However, now when i do this i get this error message:

App returned 400 and said {"errors":[{"field":"field_5","type":"unique","message":"Country must be unique. \"Thailand\" is already being used."},{"field":"field_4","type":"unique","message":"Continent must be unique. \"Asia\" is already being used."},{"fie

 

Inside knack I have tried to tick the box ‘must be unique’ and I have also tried to make the fields into aut increment

Userlevel 7
Badge +14

@Sean M 

Appears the Knack settings don’t allow for new rows to use an existing Country, hence the “must be unique” error.

Userlevel 7
Badge +12

Hi @Sean M 🙂

Did @Troy Tessalone’s reply help here? And were you able to find a way to work with the Country field in Knack? We’d love to know!