Unused Google Docs template fields not appearing in Zap

  • 26 January 2022
  • 6 replies

Hi there, 


I have been trying to create a new Google Doc from a template Doc once a Typeform is filled in. I have carefully followed the steps I could find online, and am able to successfully find the correct template document. However, my zap just does not identify the “unused template fields”, even though I have made sure to remove the formatting, use double brackets, and only use one word: they are all written like this {{name}}.


If I choose “remove” in the drop down, it does remove the fields, so I do believe that the zap is able to identify the fields. 

I would appreciate any help. 

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +12


Have you tried refreshing the fields on your set up?

Userlevel 7
Badge +14

Hi @YDScout 


  1. Try recreating those placeholders, then refreshing the list.
  2. Try changing to proper case, for example {{Phone}}

Hi @GetUWired and @Troy Tessalone , thank you for your comments. I have indeed refreshed the fields, and using the proper case does not help either. 

Userlevel 7
Badge +14


Try to completely remove and retype those {{placeholders}}.


Check your template field formatting

To correctly format your template fields in Google Docs:

  • Template fields must be wrapped in double curly braces.
  • Remove any spaces.
  • Remove any special characters like punctuation marks.

Here’s an example of a properly formatted template field: {{MyTemplateField}}.

Learn more about how to create and autopopulate a Google Docs template.

Hi @Troy Tessalone, I appreciate your support. As you can see from my screenshot my template fields are correctly formatted (curly brackets, no spaces, no special characters, all formatting removed). I also tried it using the proper case like you suggested previously. I have completely removed and retyped it many times, and refreshed the fields in Zapier, but nothing seems to work.

Any advice on how to proceed next? Could it be a faulty integration?

Userlevel 7
Badge +14

Hi @YDScout 

Could it be a faulty integration?

No, since it shows some of your {{placeholder}} fields and I use the GDoc Create Doc from template successfully all the time, altho it can be a bit finicky as you’ve encountered.

Try creating a new GDoc template?