Unable to verify that your connection has access to the Firebase/Firestore project

  • 13 January 2021
  • 4 replies
  • 2434 views

Userlevel 2

I'm new to Zapier and quite experienced when it comes to Firebase. But unable to create a task in Zapier I'm certain that I have entered my correct project id.

I have been searching for same questions and answer but can't seem to find one. This seems to more of a problem on Zapier rather than Firebase.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +12

Hi @vb4!

 

It’s tricky to know what the trouble is without knowing more about how your Zap is set up. 

 

If you think that it might be an issue with entering the right product ID could it be that you need to use the ID number and not name? Here’s a guide on using custom values that might help: Add custom values to dropdown menu fields in Zaps

 

If that’s not the issue that you’re having then you’re probably best to contact the support team so that they can take a closer look at your Zap with you. The best way to do that is with the Get Help form

Userlevel 2

Hi @Danvers,

 

Zapier is having trouble connecting to Google API if there was no existing records in your Firebase Cloud Firestore. Although, I only intend to use Firebase RTD. So, make sure to populate a sample data in your Cloud Firestore or RTD before setting up your Zap.

Thank you @vb4,

 

I’ve connected successfully before to Firebase, and was knocking my head against the desk trying to figure out why it wasn’t working in this project. I created a Firebase database (Realtime didn’t work) and populated with a few fields and Zapier connected right up.

 

:thumbsup::thumbsup::thumbsup::thumbsup::thumbsup:

Userlevel 7
Badge +11

Hi @vb4!

I see that you reached out to our Support team and they had the following to say:


I'm sorry to hear you're having some trouble with your Zap and that's not what we want here!

I did a quick check on our notes and it looks like if there is no Collection, it will return this error when authenticating.

To resolve this, simply add a new collection and it should work as intended:


Did you try that and did it end up working for you?