Unable to see records in Salesforce

  • 18 March 2021
  • 6 replies

I tried integrating Salesforce and GovSpend applications together. I used the paid account for GovSpend and trial account in SalesForce. The zapier says data is sent to my salesforce trial account. But I am unable see the data in salesforce.

I just want to understand the problem. Can you please help me figure out the issue?

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @keerthana2198sekar 

Please provide screenshots of how your Zap steps are currently configured, thanks.

1.Set up trigger :

  1. Chosen GovSpend API key of our paid account
  2. Trigger was successful
  3. Set up the action is salesforce
  4. Chosen my trial account
  5. Set up the action and provided sample data


  6. Tested the action


  7. And it said data sent to salesforce

    But, I could not see the record sent in my Salesforce trial account

Userlevel 7
Badge +14


Make sure to refresh Salesforce and check the Accounts.

Try opening an existing Account then replacing the ID in the browser URL with the ID returned from the Salesforce, such as the one seen at the end of the ‘url’ data point in the screenshot below.


I have tried as you have mentioned, but it is still saying this. I even tried refreshing the site.


Userlevel 7
Badge +14


Make sure to review these available help articles:

If the issue persists, you can open a ticket with Zapier Support here:

Userlevel 7
Badge +11

Hey @keerthana2198sekar,

I can see that you’ve written to our Support team about this and they’ve responded to you with some instructions and further questions. Are you still running into this issue?

If so, please can you continue the conversation there, since they’re able to dig into your Zaps and our detailed logs to better troubleshoot this with you.